Bug 588549 - Google Calendar invite causes evolution to crash
Summary: Google Calendar invite causes evolution to crash
Status: CLOSED DUPLICATE of bug 587726
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-mapi (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 22:21 UTC by Chad Feller
Modified: 2010-05-05 10:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 10:52:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (6.76 KB, text/plain)
2010-05-03 22:21 UTC, Chad Feller
no flags Details
backtrace (8.88 KB, text/plain)
2010-05-04 23:16 UTC, Chad Feller
no flags Details

Description Chad Feller 2010-05-03 22:21:45 UTC
Created attachment 411148 [details]
backtrace

Description of problem:
Google Calendar invite causes evolution to crash and core dump

Version-Release number of selected component (if applicable):

evolution-2.30.1-2.fc13.x86_64
evolution-mapi-0.30.1-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. open google calendar invite in evolution
2.
3.
  
Actual results:
evolution crashes

Expected results:
evolution should display message

Additional info:
abrt isn't catching this crash, I'm not sure why.  I manually spawned evolution from gdb, and created a backtrace as described here:

http://projects.gnome.org/evolution/bugs.shtml

Comment 1 Milan Crha 2010-05-04 11:26:20 UTC
Thanks for a bug report. Unfortunately I do not see anything particularly wrong in the above backtrace. Could you install also debug info packages for evolution-data-server, evolution and evolution-mapi, and try to reproduce this issue under gdb like this:
   $ gdb evolution --ex r
and when it crashes, then invoke a gdb command:
   (gdb) t a a bt
and add here all from the console involving also text just before gdb stoped on the crash, please? (It'll show there something like "Signal handler called", or similar text, and then line where the crash happened.) I believe it's pretty the same as is described in your above link.

Thanks in advance.

Comment 2 Chad Feller 2010-05-04 23:04:09 UTC
Installed:
evolution-debuginfo-2.30.1-2.fc13.x86_64
evolution-data-server-debuginfo-2.30.1-2.fc13.x86_64
evolution-mapi-debuginfo-0.30.1-1.fc13.x86_64

Comment 3 Chad Feller 2010-05-04 23:16:37 UTC
Created attachment 411428 [details]
backtrace

Comment 4 Chad Feller 2010-05-04 23:45:05 UTC
Also, it seems that any calendar invite is causing evolution to crash these days, so this may be a more generic issue.  Check out bug# 587726

Comment 5 Chad Feller 2010-05-04 23:48:41 UTC
(In reply to comment #4)
Just continuing my thought process: the interesting issue is that abrt is picking up an Exchange calender invite triggered crash, but not the Google Calendar invite triggered crash.

Comment 6 Milan Crha 2010-05-05 10:52:35 UTC
OK, thanks for the update. This one is same as bug #587726, it's in evolution-mapi. I'm marking this as a duplicate of the older, and let's move there.

*** This bug has been marked as a duplicate of bug 587726 ***


Note You need to log in before you can comment on or make changes to this bug.