Bug 588590 - 2.6.33.3-72.fc13.i686.PAE update breaks brightness on Thinkpad X100e
2.6.33.3-72.fc13.i686.PAE update breaks brightness on Thinkpad X100e
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 22:40 EDT by Jim Connor
Modified: 2013-01-10 03:08 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-09 12:37:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
acpidump output, as requested (187.45 KB, text/plain)
2010-05-04 18:24 EDT, Jim Connor
no flags Details

  None (edit)
Description Jim Connor 2010-05-03 22:40:58 EDT
Description of problem:

Brightness controls (Fn-Delete and Fn-Home) on Lenovo X100e do not work after upgrade to 2.6.33.3-72.fc13.i686.PAE. 
They worked fine with 2.6.33.2-57.fc13.i686.PAE

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Update to 2.6.33.3-72.fc13.i686.PAE with 'Software update'
2. Press Fn-Delete on Thinkpad X100e
3. Press Fn-Home on Thinkpad X100e
  
Actual results:
OSD brightness icon appears, but no change in brightness using either key combination.

Expected results:
Screen should dim or brighten as per 2.6.33.2-57.fc13.i686.PAE

Additional info:
I believe that this is the first kernel released that attempts to support the X100e as dmesg no longer displays the message 'Not yet supported ThinkPad detected!'

Further dmesg messages wrt X100e:

hinkpad_acpi: ThinkPad ACPI Extras v0.24
thinkpad_acpi: http://ibm-acpi.sf.net/
thinkpad_acpi: ThinkPad BIOS 6XET36WW (1.20a), EC 6XHT36WW-1.176000
thinkpad_acpi: Lenovo ThinkPad X100e, model 3508CTO
thinkpad_acpi: possible tablet mode switch found; ThinkPad in laptop mode
thinkpad_acpi: asked for hotkey mask 0x040988fc, but firmware forced it to 0x000988fc
Registered led device: tpacpi::thinklight
Registered led device: tpacpi::power
Registered led device: tpacpi::standby
Registered led device: tpacpi::thinkvantage
thinkpad_acpi: Console audio control enabled, mode: monitor (read only)
input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input8

Would be happy to provide any other logs, if requested.
Comment 1 Jim Connor 2010-05-03 22:43:19 EDT
Boot parameters:
kernel /vmlinuz-2.6.33.3-72.fc13.i686.PAE ro root=/dev/mapper/VolGroup-lv_root rd_LVM_LV=VolGroup/lv_root rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet radeon.modeset=0
Comment 2 Matthew Garrett 2010-05-04 14:41:20 EDT
Could you install the pmtools package and provide the output of the acpidump command? Also, please attach the output of ls -R /sys/class/backlight .
Comment 3 Jim Connor 2010-05-04 15:01:27 EDT
(In reply to comment #2)
> Could you install the pmtools package and provide the output of the acpidump
> command? Also, please attach the output of ls -R /sys/class/backlight .    

Yes. I'll do that this evening. Thanks for looking at this!
Comment 4 Jim Connor 2010-05-04 18:24:38 EDT
Created attachment 411421 [details]
acpidump output, as requested
Comment 5 Jim Connor 2010-05-04 18:25:54 EDT
(In reply to comment #2)
> Could you install the pmtools package and provide the output of the acpidump
> command? Also, please attach the output of ls -R /sys/class/backlight .    

[root@localhost ~]# ls -R /sys/class/backlight/
/sys/class/backlight/:
acpi_video0  thinkpad_screen
[root@localhost ~]# cd /sys/class/backlight/
[root@localhost backlight]# ll
total 0
lrwxrwxrwx 1 root root 0 May  4 18:15 acpi_video0 -> ../../devices/virtual/backlight/acpi_video0
lrwxrwxrwx 1 root root 0 May  4 18:15 thinkpad_screen -> ../../devices/virtual/backlight/thinkpad_screen
Comment 6 Matthew Garrett 2010-05-05 08:33:49 EDT
Hm. Interesting. If you write numeric valies into /sys/class/backlight/acpi_video0/brightness, does the brightness change?
Comment 7 Jim Connor 2010-05-05 09:25:02 EDT
(In reply to comment #6)
> Hm. Interesting. If you write numeric valies into
> /sys/class/backlight/acpi_video0/brightness, does the brightness change?    

I'll try this evening. I don't have physical access to the machine during the day, so I could change the value, but I can't see the result from here!

BTW, here are the current values:

[jim@localhost acpi_video0]$ pwd
/sys/class/backlight/acpi_video0
[jim@localhost acpi_video0]$ ls -l
total 0
-r--r--r-- 1 root root 4096 May  5 09:15 actual_brightness
-rw-r--r-- 1 root root 4096 May  5 09:15 bl_power
-rw-r--r-- 1 root root 4096 May  5 09:15 brightness
lrwxrwxrwx 1 root root    0 May  5 07:15 device -> ../../../LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:1f/LNXVIDEO:00/device:20
-r--r--r-- 1 root root 4096 May  5 07:15 max_brightness
drwxr-xr-x 2 root root    0 May  5 09:15 power
lrwxrwxrwx 1 root root    0 May  5 07:15 subsystem -> ../../../../class/backlight
-rw-r--r-- 1 root root 4096 May  5 07:15 uevent
[jim@localhost acpi_video0]$ cat actual_brightness 
15
[jim@localhost acpi_video0]$ cat bl_power 
0
[jim@localhost acpi_video0]$ cat brightness 
0
[jim@localhost acpi_video0]$ cat max_brightness 
15

BTW, FWIW I am able to use the Gnome Power Manager Brightness Applet to change the brightness. The UI is a bit busted, but can be used (another bug report!)
I had turned the brightness down, with the applet, which might explain the 'brightness' value of zero, but the fact that the 'actual_brightness' is 15 isn't what I would have expected!
Comment 8 Matthew Garrett 2010-05-05 09:53:02 EDT
I think I see the problem. I'm doing a test kernel build now, can you test it when you get access to the machine again?
Comment 9 Jim Connor 2010-05-05 10:05:49 EDT
Cool. Sure, let me know where I can get it (koji?) and I'll try it tonight.
Comment 10 Matthew Garrett 2010-05-05 10:14:25 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=2164764 once it's finished.
Comment 11 Jim Connor 2010-05-05 18:42:35 EDT
Hi Matthew,

I've installed the kernel but key brightness keys still don't work.

[jim@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.33.3-83.fc13.i686.PAE #1 SMP Wed May 5 14:45:48 UTC 2010 i686 i686 i386 GNU/Linux
Comment 12 Jim Connor 2010-05-05 20:18:22 EDT
I wrote some values to /sys/class/backlight/acpi_video0/brightness and the brightness levels did change as expected (back using the 2.6.33.3-72.fc13.i686.PAE kernel). I also noted that the /sys/class/backlight/acpi_video0/actual_brightness file was automagically updated to match.
Comment 13 Matthew Garrett 2010-05-06 07:47:01 EDT
How many entries did you have in /sys/class/backlight when using the test kernel?
Comment 14 Jim Connor 2010-05-06 09:36:18 EDT
That I didn't think to check. I'll do so tonight.

Also, please confirm that this is the kernel I should be testing with:
http://koji.fedoraproject.org/koji/getfile?taskID=2164767&name=kernel-PAE-2.6.33.3-83.fc13.i686.rpm

and not this one on the main koji page.
http://kojipkgs.fedoraproject.org/packages/kernel/2.6.33.3/83.fc13/i686/kernel-PAE-2.6.33.3-83.fc13.i686.rpm

They both have the same version number.
Comment 15 Jim Connor 2010-05-06 18:29:13 EDT
(In reply to comment #13)
> How many entries did you have in /sys/class/backlight when using the test
> kernel?    

Looks the same.

[root@localhost backlight]# ls -l
total 0
lrwxrwxrwx 1 root root 0 May  6 18:19 acpi_video0 -> ../../devices/virtual/backlight/acpi_video0
lrwxrwxrwx 1 root root 0 May  6 18:19 thinkpad_screen -> ../../devices/virtual/backlight/thinkpad_screen
[root@localhost backlight]#
Comment 16 Matthew Garrett 2010-05-07 13:15:08 EDT
Ok, that indicates that there was something wrong with my patch. The problem is that thinkpad-acpi is providing a backlight control when it shouldn't be and the wrong backlight control is being used.
Comment 17 Jim Connor 2010-05-07 13:36:42 EDT
My understanding is that thinkpad-acpi only recently added the X100e to its list of recognized machines, so perhaps that's were the conflict arose. The previously released kernel did not recognize the X100e but the back light controls did actually work!

Anyway, whenever you want me to try another patch, let me know.
Comment 18 Christian Funke 2010-05-19 03:35:10 EDT
I also have a Thinkpad X100e and I am also bitten by this bug. It still persists with kernel-2.6.33.4-95.fc13.x86_64. I found out that blacklisting thinkpad_acpi actually restores the functionality of the brightness controls, the keys are also correctly recognized by KDE. The Mute and Volume keys also work fine. I havent checked the Switch output keys yet.
Comment 19 Matthew Garrett 2011-02-09 12:02:07 EST
Does this still happen with the current kernels? I'm afraid I don't have access to an X100e to check.
Comment 20 Christian Funke 2011-02-09 12:31:06 EST
This problem went away somewhere in the 2.6.34 kernels and did not resurface on Fedora 14. I am currently using the latetest updates-testing kernel in F14.From my point of view this bug is fixed.

Thanks for your work
Comment 21 Matthew Garrett 2011-02-09 12:37:35 EST
Ok, thanks - I did some work on this in August but forgot to update the bug. Glad this is fixed, and thanks for the update!

Note You need to log in before you can comment on or make changes to this bug.