Bug 58863 - xsri: include vroot.h
xsri: include vroot.h
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xsri (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-25 19:08 EST by Jamie Zawinski
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 19:08:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Zawinski 2002-01-25 19:08:45 EST
xsri does not undertstand virtual root windows.  This means:

  - it cannot be used to set the background with virtual-root window managers;
  - it cannot be used as a slideshow displayer with xscreensaver.

I would like to add "xsri" to the list of programs that xscreensaver tries
to use to put images on the screen (as "xv", "chbg" and "xsetroot" are
not always available, but "xsri" seems pretty common) but I can't,
because it doesn't work.

All you need to do is add "#include <vroot.h>" to any files that
call RootWindow or RootWindowOfScreen.  If you don't have
vroot.h, snarf it from xscreensaver/utils/

xsri-2.0.3-1
Comment 1 Owen Taylor 2002-02-11 15:44:34 EST
Mon Feb 11 15:08:07 2002  Owen Taylor  <otaylor@redhat.com>

	* Version 2.1.0

	* render-background.c (get_root_xwindow): Support
	__SWM_VROOT style fake root windows so that xsri can be
	used by xscreensaver.

Note You need to log in before you can comment on or make changes to this bug.