This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 588644 - CRC error on valid file
CRC error on valid file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gzip (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Karel Klíč
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 608787
  Show dependency treegraph
 
Reported: 2010-05-04 03:56 EDT by Stefan Sørensen
Modified: 2013-03-03 18:00 EST (History)
3 users (show)

See Also:
Fixed In Version: gzip-1.3.13-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 608787 (view as bug list)
Environment:
Last Closed: 2010-07-01 15:00:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Sørensen 2010-05-04 03:56:23 EDT
Description of problem:
gzip fails to decompress valid compressed files.


Version-Release number of selected component (if applicable):
gzip-1.3.13-3.fc13.i686 

How reproducible:
Always

Steps to Reproduce:
1. wget http://downloads.sourceforge.net/expat/expat-2.0.1.tar.gz
2. gzip -t expat-2.0.1.tar.gz
  
Actual results:
Fails with "invalid compressed data--crc error"

Expected results:
Test succeeds.

Additional info:
Same file runs fine on F12 box with all updates.
Comment 1 Stefan Sørensen 2010-05-04 06:24:02 EDT
The build is broken by gzip-1.3.13-rsync.patch - rebuilding without solves the problem.
Comment 2 Karel Klíč 2010-05-05 08:02:33 EDT
I cannot reproduce it on my machine (i686). 

`gzip -t expat-2.0.1.tar.gz` succeeds both with F-12 and F-13.

Do you use x86_64?
Comment 3 Karel Klíč 2010-05-05 08:15:31 EDT
Ah, you also have i686, sorry.

I also tested it on F-13 x86_64 and `gzip -t expat-2.0.1.tar.gz` works there as well. 

Do we have the same expat-2.0.1.tar.gz?

$ md5sum expat-2.0.1.tar.gz 
ee8b492592568805593f81f8cdf2a04c  expat-2.0.1.tar.gz
Comment 4 Stefan Sørensen 2010-05-05 08:24:03 EDT
Yes, same md5sum. Ubuntu seems to have the same bug: https://bugs.launchpad.net/bugs/524366
Comment 5 Karel Klíč 2010-05-10 11:31:29 EDT
The preferred solution for me is to remove the rsync patch. It failed to find its way to the upstream release, and now it causes problems that cannot be easily reproduced.

I'll remove that patch from Rawhide if no fix is found in reasonable time.
Comment 6 Karel Klíč 2010-06-28 10:48:48 EDT
Most likely the issue was not caused by the rsync patch.
Via launchpad:
http://git.savannah.gnu.org/cgit/gzip.git/commit/?id=b9e94c93df914bd1d9eec9f150b2e4e00702ae7b
Comment 7 Fedora Update System 2010-06-28 10:52:12 EDT
gzip-1.3.13-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gzip-1.3.13-4.fc13
Comment 8 Fedora Update System 2010-06-28 19:36:54 EDT
gzip-1.3.13-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gzip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gzip-1.3.13-4.fc13
Comment 9 Stefan Sørensen 2010-06-29 03:22:37 EDT
gzip-1.3.13-4.fc13 fixes the problem for me.
Comment 10 Fedora Update System 2010-07-01 15:00:35 EDT
gzip-1.3.13-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.