Bug 588648 - RFE: Provide option to show password when encrypting disk
RFE: Provide option to show password when encrypting disk
Status: CLOSED DUPLICATE of bug 582536
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 04:03 EDT by Kamil Páral
Modified: 2010-05-04 08:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 08:30:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2010-05-04 04:03:11 EDT
Description of problem:
When selecting "Encrypt system" option in disk partitioning, a new dialog appears prompting for new password. Please add a checkbox "show password". Password for the whole system is a critical information, I must be absolutely sure I entered it correctly. Without seeing the password, I can't be sure.

Have in mind that I can have different keyboard layout selected and I may want to encrypt disk with non-ascii characters. Even when I chose my preferred keyboard layout, I can't be absolutely sure all the keys are placed where I suppose them. Then it may happen I provide the same password twice, but the password is different from what I suppose, and when I replace my keyboard some time in the future, I won't be able to unlock my disk anymore.

Version-Release number of selected component (if applicable):
Fedora 13 Final TC1
anaconda-13.39
Comment 1 Kamil Páral 2010-05-04 04:25:35 EDT
To provide one more (stronger) reason: Some keyboard layouts are currently broken and exactly what I described now happened. I have encrypted my disk with some characters and I don't know which ones. I just know for sure it weren't those characters I had in mind.
Comment 2 Chris Lumens 2010-05-04 08:30:34 EDT
We are not going to add a checkbox to display the password, but we can certainly investigate adding something to the keyboard screen to let you test out your keyboard layout before you agree to that, just to make sure the keyboard layout works as intended.

*** This bug has been marked as a duplicate of bug 582536 ***

Note You need to log in before you can comment on or make changes to this bug.