Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 588668 - F13: don't probe for RAIDs on CD-ROMs
F13: don't probe for RAIDs on CD-ROMs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 04:58 EDT by Karel Zak
Modified: 2010-06-14 06:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 588248
Environment:
Last Closed: 2010-06-14 06:15:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Zak 2010-05-04 04:58:23 EDT
+++ This bug was initially created as a clone of Bug #588248 +++

Description of problem:

RAID probing of CD/DVD can yield errors because of well-known problem
in reading the end of the disk with some disk/drive combinations.

More information (upstream):
http://thread.gmane.org/gmane.linux.utilities.util-linux-ng/3114


The problem is not possible to reproduce without the (broken) hardware, but it's possible to check that blkid(8) does not read from last sectors from the probed device. For example

 strace -e read blkid /dev/cdrom

--- Additional comment from kzak@redhat.com on 2010-05-03 05:36:31 EDT ---

Note that you can also use 

  BLKID_DEBUG=0xffff blkid -p -o udev /dev/cdrom

to check that libblkid does not call RAID probing functions. (The -p should be also used tor the previous example with "strace".)
Comment 1 Fedora Update System 2010-05-04 05:17:28 EDT
util-linux-ng-2.17.2-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/util-linux-ng-2.17.2-4.fc13
Comment 2 Fedora Update System 2010-05-10 19:52:19 EDT
util-linux-ng-2.17.2-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.