Bug 588673 - SELinux is preventing /usr/bin/passwd "write" access on socket.
SELinux is preventing /usr/bin/passwd "write" access on socket.
Status: CLOSED DUPLICATE of bug 588672
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:012baea5ffe...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 05:06 EDT by alextazy0
Modified: 2010-06-01 20:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 08:49:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description alextazy0 2010-05-04 05:06:05 EDT
Résumé:

SELinux is preventing /usr/bin/passwd "write" access on socket.

Description détaillée:

[SELinux est en mode permissif. Cet accès n'a pas été refusé.]

SELinux denied access requested by passwd. It is not expected that this access
is required by passwd and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Autoriser l'accès:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Informations complémentaires:

Contexte source               unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023
Contexte cible                unconfined_u:object_r:tmp_t:s0
Objets du contexte            socket [ sock_file ]
source                        passwd
Chemin de la source           /usr/bin/passwd
Port                          <Inconnu>
Hôte                         (removed)
Paquetages RPM source         passwd-0.77-1.fc12
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.6.32-110.fc12
Selinux activé               True
Type de politique             targeted
Mode strict                   Permissive
Nom du plugin                 catchall
Nom de l'hôte                (removed)
Plateforme                    Linux (removed) 2.6.32.11-99.fc12.i686 #1 SMP
                              Mon Apr 5 16:32:08 EDT 2010 i686 i686
Compteur d'alertes            1
Première alerte              lun. 03 mai 2010 22:02:40 CEST
Dernière alerte              lun. 03 mai 2010 22:02:40 CEST
ID local                      ea73078f-8ded-4bd0-8595-c72402a3a3fe
Numéros des lignes           

Messages d'audit bruts        

node=(removed) type=AVC msg=audit(1272916960.296:31259): avc:  denied  { write } for  pid=3882 comm="passwd" name="socket" dev=sda2 ino=813199 scontext=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmp_t:s0 tclass=sock_file

node=(removed) type=SYSCALL msg=audit(1272916960.296:31259): arch=40000003 syscall=102 success=yes exit=0 a0=3 a1=bf85d830 a2=2344d4 a3=93fab8d items=0 ppid=3872 pid=3882 auid=501 uid=501 gid=501 euid=501 suid=501 fsuid=501 egid=501 sgid=501 fsgid=501 tty=pts2 ses=14 comm="passwd" exe="/usr/bin/passwd" subj=unconfined_u:unconfined_r:passwd_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,passwd,passwd_t,tmp_t,sock_file,write
audit2allow suggests:

#============= passwd_t ==============
allow passwd_t tmp_t:sock_file write;
Comment 1 Miroslav Grepl 2010-05-04 08:49:51 EDT

*** This bug has been marked as a duplicate of bug 588672 ***

Note You need to log in before you can comment on or make changes to this bug.