Bug 588702 - v7 incorrectly uses 'processor.can_throttle' to plan CPUSCALING tests
Summary: v7 incorrectly uses 'processor.can_throttle' to plan CPUSCALING tests
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)   
(Show other bugs)
Version: 1.1
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Qian Cai
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-04 10:37 UTC by Gary Smith
Modified: 2018-10-27 13:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The CPU scaling test now checks the content of /sys/devices/system/cpu/cpu<n>/cpufreq/scaling_available_frequencies file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 12:14:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cpuscaling test patch to check /sys/../cpu<n>/cpufreq/scaling_available_frequencies for test planning (999 bytes, patch)
2010-07-28 17:44 UTC, Greg Nichols
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0702 normal SHIPPED_LIVE v7 bug fix and enhancement update 2010-10-21 07:59:09 UTC

Description Gary Smith 2010-05-04 10:37:43 UTC
The v7 cert suite uses the info “processor.can_throttle = true (bool)” to find out if the CPUs are scalable. This is incorrect because:

throttling (T states)

..are different to:

cpu_scaling (C states)

In some old documents it seems to be the same, but there’s now a mandatory difference between both states.

A system can offer “cpu_scaling”, but must not offer “throttling”. It depends what is implemented in the BIOS.

It is being 'assumed' (but not yet proven) that this is the reason that 'v7 plan' never automatically adds CPUSCALING tests to the plan on Fujitsu hardware.


Actual results:
v7 does not automatically add CPUSCALING tests for each core on Fujitsu hardware


Expected results:
v7 should automatically add CPUSCALING tests for each core on Fujitsu hardware

Comment 1 Bob Sanders 2010-06-29 16:01:59 UTC
We're seeing the same issue at SGI.  With Intel 5600 cpus and AMI bios, 
cpuscaling is not turned on by v7.  But with the same cpus and an Intel
bios cpu scaling is automatically selected.

Bob

Comment 3 Greg Nichols 2010-07-28 17:44:25 UTC
Created attachment 435093 [details]
cpuscaling test patch to check /sys/../cpu<n>/cpufreq/scaling_available_frequencies for test planning

Comment 9 errata-xmlrpc 2010-09-20 12:14:13 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0702.html

Comment 10 Jaromir Hradilek 2010-09-21 12:52:51 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The CPU scaling test now checks the content of /sys/devices/system/cpu/cpu<n>/cpufreq/scaling_available_frequencies file.


Note You need to log in before you can comment on or make changes to this bug.