Bug 588737 - Missing icon
Summary: Missing icon
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 588538
TreeView+ depends on / blocked
 
Reported: 2010-05-04 12:31 UTC by Lubomir Rintel
Modified: 2010-07-02 20:48 UTC (History)
4 users (show)

Fixed In Version: anaconda-13.21.40-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 20:48:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
icons files, meant for placement in /usr/share/icons/hicolor/*, artwork by Jakub Steiner, Lapo Calamandrei, Máirín Duffy (8.42 KB, application/x-bzip)
2010-05-05 14:32 UTC, Máirín Duffy
no flags Details
preview showing what the new icon looks like (6.50 KB, image/png)
2010-05-05 14:32 UTC, Máirín Duffy
no flags Details

Description Lubomir Rintel 2010-05-04 12:31:27 UTC
An icon for liveinst is missing:

[liveuser@localhost ~]$ cat /usr/share/applications/liveinst.desktop |grep Icon
Icon=anaconda
[liveuser@localhost ~]$ find /usr/share/icons /usr/share/pixmaps |grep anaconda
[liveuser@localhost ~]$

Furthermore, the package contains a broken symlink:

[liveuser@localhost ~]$ file /usr/share/pixmaps/redhat/mini-\*.xpm
/usr/share/pixmaps/redhat/mini-*.xpm: broken symbolic link to `*-mini.xpm'

Obviously, there's nothing like *-mini.xpm in the sources:

(cd $RPM_BUILD_ROOT%{_datadir}/pixmaps/redhat; \
for i in *-mini.xpm; do \
  linkfile=`echo $i | sed -e "s/\(.*\)-mini/mini-\1/"` ; \
  ln -s $i $linkfile ; \
done)

Comment 2 RHEL Product and Program Management 2010-05-04 13:30:17 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Ray Strode [halfline] 2010-05-04 16:46:14 UTC
looks like we need the rhel equivalent of fedora's anaconda.png, which is a fedora logo with an arrow pointing to a harddrive

Comment 4 Ray Strode [halfline] 2010-05-04 16:50:50 UTC
Adding Máirín to the cc list

Comment 5 Máirín Duffy 2010-05-05 14:32:09 UTC
Created attachment 411631 [details]
icons files, meant for placement in /usr/share/icons/hicolor/*, artwork by Jakub Steiner, Lapo Calamandrei, Máirín Duffy

Comment 6 Máirín Duffy 2010-05-05 14:32:49 UTC
Created attachment 411633 [details]
preview showing what the new icon looks like

Comment 7 Ray Strode [halfline] 2010-05-05 14:57:29 UTC
New icons aren't branded, they need to go in anaconda.

Reassigning.

Comment 8 David Cantrell 2010-05-08 02:34:56 UTC
Have a patch in place for anaconda to include these icons.  Can I get a qa_ack on this bug so I can commit the fix?

Comment 11 Alexander Todorov 2010-05-25 13:20:32 UTC
anaconda-13.21.45-1.el6.x86_64

# grep Icon /usr/share/applications/liveinst.desktop 
Icon=anaconda

# find /usr/share/icons /usr/share/pixmaps |grep anaconda
/usr/share/icons/hicolor/48x48/apps/anaconda.png
/usr/share/icons/hicolor/32x32/apps/anaconda.png
/usr/share/icons/hicolor/16x16/apps/anaconda.png
/usr/share/icons/hicolor/22x22/apps/anaconda.png
/usr/share/icons/hicolor/24x24/apps/anaconda.png

Icon is present.

# ls -l /usr/share/pixmaps/redhat/*mini*
-rw-r--r--. 1 root root 458  1 Jun  2009 /usr/share/pixmaps/redhat/rpmlogo-mini.png

No symlinks found. Moving to VERIFIED.

Comment 12 releng-rhel@redhat.com 2010-07-02 20:48:28 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.