Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 588748 - Additional dashes printed in PDF documents
Summary: Additional dashes printed in PDF documents
Keywords:
Status: CLOSED DUPLICATE of bug 577068
Alias: None
Product: Publican
Classification: Community
Component: publican
Version: 1.6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn 🐞
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-04 12:43 UTC by Andrew Beekhof
Modified: 2010-11-24 04:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-04 21:55:29 UTC


Attachments (Terms of Use)

Description Andrew Beekhof 2010-05-04 12:43:23 UTC
Description of problem:

Spaces in <screen> elements are expanded into unicode 0xA0 (nbsp) + 0xAD (soft hyphen).
When fop sees a following unicode 2D '-', the soft hyphen is printed.

so <screen> command --help -?</screen> actually comes out as "command ---help --?".


Version-Release number of selected component (if applicable):

1.6.1 and 1.6.2
1.1 did not have this problem. For now I have downgraded.

How reproducible:

Always
Have tested with custom and default brands.

Steps to Reproduce:
1. In a document, add <screen> command --help -?</screen>
2. Build the pdf version of the document
3. Open pdf
  
Actual results:

Text displayed as "command ---help --?".

Expected results:

Text displayed as "command --help -?".


Additional info:

Name        : fop                          Relocations: (not relocatable)
Version     : 0.95                              Vendor: Fedora Project
Release     : 4                             Build Date: Sat 25 Jul 2009 08:36:01 PM CEST

Comment 1 Jeff Fearn 🐞 2010-05-04 21:55:29 UTC

*** This bug has been marked as a duplicate of bug 577068 ***


Note You need to log in before you can comment on or make changes to this bug.