Bug 588763 - libguestfs should use non-public or link-local addresses for appliance network
libguestfs should use non-public or link-local addresses for appliance network
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 09:24 EDT by Richard W.M. Jones
Modified: 2010-05-12 07:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-12 07:49:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-05-04 09:24:25 EDT
Description of problem:

When running network commands (eg. using
http://libguestfs.org/guestfs.3.html#guestfs_command ),
these can fail if they access a public service on the 10.x.x.x
network.  For example, if trying to run 'yum update' and if
yum has been configured to use a yum server or proxy which
is within the local network and therefore has a 10.x.x.x address.

This happens because inside the appliance we use qemu's
userspace network to talk from daemon to host library, and
qemu's userspace network by default is set to use the 10.x.x.x
address space for its own purposes.

Proposed solution is to switch to using link local addresses,
see: http://tools.ietf.org/html/rfc3927

Version-Release number of selected component (if applicable):

libguestfs 1.3.9

How reproducible:

Always.

Steps to Reproduce:
1. Run 'sh "yum -y update"'

Actual results:

Fails if the network command has to access any network
service which resolves to 10.x.x.x address.

Expected results:

Should not fail.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.