Bug 588795 - [abrt] crash in mc-1:4.7.1-2.fc13: Process /usr/bin/mc was killed by signal 11 (SIGSEGV)
[abrt] crash in mc-1:4.7.1-2.fc13: Process /usr/bin/mc was killed by signal 1...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
abrt_hash:ac0e3255b4072813d6b945702e9...
:
: 586459 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 10:40 EDT by Pavel Alexeev
Modified: 2013-07-02 19:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: mc-4.7.5-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-21 17:56:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (9.29 KB, text/plain)
2010-05-04 10:40 EDT, Pavel Alexeev
no flags Details

  None (edit)
Description Pavel Alexeev 2010-05-04 10:40:48 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/bin/mc -P /tmp/mc-pasha/mc.pwd.4441
comment: Segfault always reproduced.
component: mc
executable: /usr/bin/mc
global_uuid: ac0e3255b4072813d6b945702e9b9a8e271f6d5d
kernel: 2.6.33.1-24.fc13.i686
package: mc-1:4.7.1-2.fc13
rating: 4
reason: Process /usr/bin/mc was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Open file to edit on FTP
2. Wait until timeout cahe expired
3. Try save file
Comment 1 Pavel Alexeev 2010-05-04 10:40:50 EDT
Created attachment 411322 [details]
File: backtrace
Comment 2 Slava Zanko 2010-05-05 05:15:04 EDT
Unable to reproduce.

Pavel, If it's not hard: please check this behaviour on your system with mc from git (master or stable branches).

This bugreport looks like http://midnight-commander.org/ticket/2065 (some troubles with VFS), but I'm dont fully sure - need to check.
Comment 3 Pavel Alexeev 2010-05-05 05:31:27 EDT
Ehh, it need building...

Ok, thank you Slava, I'll try it some later.
Comment 4 Jindrich Novy 2010-05-06 00:55:32 EDT
Please try to install the latest mc-4.7.2 from updates-testing if you don't want to build it.

https://admin.fedoraproject.org/updates/mc-4.7.2-1.fc13
Comment 5 Pavel Alexeev 2010-05-06 07:16:03 EDT
Thank you, Jindrich, with rpm it simpler to test.

And no, bug still reproduced.

Some more details: If save via F2 and save dialog it work, but if exit from file editing and choose save from appeared dialog it segfaulted.
Comment 6 Karel Klíč 2010-11-08 13:28:33 EST
*** Bug 586459 has been marked as a duplicate of this bug. ***
Comment 7 Jindrich Novy 2010-12-08 09:13:12 EST
Could you please try these packages?

http://koji.fedoraproject.org/koji/taskinfo?taskID=2651525

I added patch to fix the vfs_s_generate_entry(). I will release updates if I
don't see a negative reply in two weeks.
Comment 8 Fedora Update System 2010-12-09 05:07:12 EST
mc-4.7.4-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mc-4.7.4-3.fc13
Comment 9 Fedora Update System 2010-12-09 17:00:12 EST
mc-4.7.4-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/mc-4.7.4-3.fc13
Comment 10 Fedora Update System 2011-01-12 12:15:32 EST
mc-4.7.5-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/mc-4.7.5-1.fc13
Comment 11 Fedora Update System 2011-01-13 12:59:45 EST
mc-4.7.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mc'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/mc-4.7.5-1.fc13
Comment 12 Fedora Update System 2011-01-21 17:56:24 EST
mc-4.7.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.