Bug 588800 - possible recursive locking detected
possible recursive locking detected
Status: CLOSED DUPLICATE of bug 571969
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 12:24 EDT by Nathanael Noblet
Modified: 2010-05-05 04:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 04:25:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathanael Noblet 2010-05-04 12:24:23 EDT
Description of problem:
When shutting down I get the following - the debug version - 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Shutdown using kernel with debugging code enabled
2.
3.
  
Actual results:
May  2 21:00:03 iridium kernel:
May  2 21:00:03 iridium kernel: =============================================
May  2 21:00:03 iridium kernel: [ INFO: possible recursive locking detected ]
May  2 21:00:03 iridium kernel: 2.6.33.1-24.fc13.x86_64 #1
May  2 21:00:03 iridium kernel: ---------------------------------------------
May  2 21:00:03 iridium kernel: K99cpuspeed/16200 is trying to acquire lock:
May  2 21:00:03 iridium kernel: (s_active){++++.+}, at: [<ffffffff81177332>] sysfs_addrm_finish+0x36/0x55
May  2 21:00:03 iridium kernel:
May  2 21:00:03 iridium kernel: but task is already holding lock:
May  2 21:00:03 iridium kernel: (s_active){++++.+}, at: [<ffffffff811774ee>] sysfs_get_active_two+0x24/0x48
May  2 21:00:03 iridium kernel:
May  2 21:00:03 iridium kernel: other info that might help us debug this:
May  2 21:00:03 iridium kernel: 4 locks held by K99cpuspeed/16200:
May  2 21:00:03 iridium kernel: #0:  (&buffer->mutex){+.+.+.}, at: [<ffffffff81175edb>] sysfs_write_file+0x3c/0x144
May  2 21:00:03 iridium kernel: #1:  (s_active){++++.+}, at: [<ffffffff811774ee>] sysfs_get_active_two+0x24/0x48
May  2 21:00:03 iridium kernel: #2:  (s_active){++++.+}, at: [<ffffffff811774fb>] sysfs_get_active_two+0x31/0x48
May  2 21:00:03 iridium kernel: #3:  (dbs_mutex){+.+.+.}, at: [<ffffffffa030ada2>] cpufreq_governor_dbs+0x2a0/0x352 [cpufreq_ondemand]
May  2 21:00:03 iridium kernel:
May  2 21:00:03 iridium kernel: stack backtrace:
May  2 21:00:03 iridium kernel: Pid: 16200, comm: K99cpuspeed Not tainted 2.6.33.1-24.fc13.x86_64 #1
May  2 21:00:03 iridium kernel: Call Trace:
May  2 21:00:03 iridium kernel: [<ffffffff8107e96b>] __lock_acquire+0xcb5/0xd2c
May  2 21:00:03 iridium kernel: [<ffffffff8107cf64>] ? mark_held_locks+0x52/0x70
May  2 21:00:03 iridium kernel: [<ffffffff8107d345>] ? debug_check_no_locks_freed+0x12e/0x145
May  2 21:00:03 iridium kernel: [<ffffffff8107d1e4>] ? trace_hardirqs_on_caller+0x111/0x135
May  2 21:00:03 iridium kernel: [<ffffffff8107eabe>] lock_acquire+0xdc/0x102
May  2 21:00:03 iridium kernel: [<ffffffff81177332>] ? sysfs_addrm_finish+0x36/0x55
May  2 21:00:03 iridium kernel: [<ffffffff8107c31c>] ? lockdep_init_map+0x9e/0x113
May  2 21:00:03 iridium kernel: [<ffffffff81176b02>] sysfs_deactivate+0x9a/0x103
May  2 21:00:03 iridium kernel: [<ffffffff81177332>] ? sysfs_addrm_finish+0x36/0x55
May  2 21:00:03 iridium kernel: [<ffffffff81071226>] ? sched_clock_cpu+0xc3/0xce
May  2 21:00:03 iridium kernel: [<ffffffff8147748c>] ? __mutex_unlock_slowpath+0x120/0x132
May  2 21:00:03 iridium kernel: [<ffffffff81177332>] sysfs_addrm_finish+0x36/0x55
May  2 21:00:03 iridium kernel: [<ffffffff81175590>] sysfs_hash_and_remove+0x53/0x6a
May  2 21:00:03 iridium kernel: [<ffffffff81178729>] sysfs_remove_group+0x91/0xca
May  2 21:00:03 iridium kernel: [<ffffffffa030adb6>] cpufreq_governor_dbs+0x2b4/0x352 [cpufreq_ondemand]
May  2 21:00:03 iridium kernel: [<ffffffff8107d215>] ? trace_hardirqs_on+0xd/0xf
May  2 21:00:03 iridium kernel: [<ffffffff813a2e37>] __cpufreq_governor+0x9b/0xde
May  2 21:00:03 iridium kernel: [<ffffffff813a3c83>] __cpufreq_set_policy+0x1ce/0x275
May  2 21:00:03 iridium kernel: [<ffffffff813a41a7>] store_scaling_governor+0x1a7/0x1fb
May  2 21:00:03 iridium kernel: [<ffffffff813a44b0>] ? handle_update+0x0/0x39
May  2 21:00:03 iridium kernel: [<ffffffff81477da7>] ? down_write+0x7a/0x81
May  2 21:00:03 iridium kernel: [<ffffffff813a3a90>] store+0x61/0x86
May  2 21:00:03 iridium kernel: [<ffffffff81175fa7>] sysfs_write_file+0x108/0x144
May  2 21:00:03 iridium kernel: [<ffffffff8111f0e5>] vfs_write+0xae/0x10b
May  2 21:00:03 iridium kernel: [<ffffffff8107d1e4>] ? trace_hardirqs_on_caller+0x111/0x135
May  2 21:00:03 iridium kernel: [<ffffffff8111f202>] sys_write+0x4a/0x6e
May  2 21:00:03 iridium kernel: [<ffffffff81009c72>] system_call_fastpath+0x16/0x1b


Expected results:

not that ;)

Additional info:
Comment 1 Anton Arapov 2010-05-05 04:25:40 EDT
thanks for the report!

*** This bug has been marked as a duplicate of bug 571969 ***

Note You need to log in before you can comment on or make changes to this bug.