Bug 588846 - [abrt] crash in python-pep8-0.4.2-2.fc12: pep8.py:703:__init__:IOError: [Errno 2] No such file or directory: 'translate/lang/th.py'
Summary: [abrt] crash in python-pep8-0.4.2-2.fc12: pep8.py:703:__init__:IOError: [Errn...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pep8
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ian Weller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a421e00a
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-04 17:39 UTC by Dwayne Bailey
Modified: 2010-05-04 20:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-04 20:14:39 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (744 bytes, text/plain)
2010-05-04 17:39 UTC, Dwayne Bailey
no flags Details

Description Dwayne Bailey 2010-05-04 17:39:48 UTC
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/pep8 --repeat translate/lang/th.py
comment: The program should probably exit more elegantly when it is asked to run over a non-existant file.
component: python-pep8
executable: /usr/bin/pep8
kernel: 2.6.32.11-99.fc12.i686.PAE
package: python-pep8-0.4.2-2.fc12
reason: pep8.py:703:__init__:IOError: [Errno 2] No such file or directory: 'translate/lang/th.py'
release: Fedora release 12 (Constantine)

backtrace
-----
pep8.py:703:__init__:IOError: [Errno 2] No such file or directory: 'translate/lang/th.py'

Traceback (most recent call last):
  File "/usr/bin/pep8", line 8, in <module>
    load_entry_point('pep8==0.4.2', 'console_scripts', 'pep8')()
  File "/usr/lib/python2.6/site-packages/pep8.py", line 1149, in _main
    input_file(path)
  File "/usr/lib/python2.6/site-packages/pep8.py", line 906, in input_file
    errors = Checker(filename).check_all()
  File "/usr/lib/python2.6/site-packages/pep8.py", line 703, in __init__
    self.lines = open(filename).readlines()
IOError: [Errno 2] No such file or directory: 'translate/lang/th.py'

Local variables in innermost frame:
self: <pep8.Checker instance at 0x928c36c>
filename: 'translate/lang/th.py'

How to reproduce
-----
1. Try to run pep8 against any non-existant file

Comment 1 Dwayne Bailey 2010-05-04 17:39:55 UTC
Created attachment 411346 [details]
File: backtrace

Comment 2 Ian Weller 2010-05-04 20:14:39 UTC
This is not a bug -- pylint isn't written to have a nice error message when you run it on a file that doesn't exist; a traceback is expected.


Note You need to log in before you can comment on or make changes to this bug.