Bug 588898 - if a node originates more then 512 messages in recovery it will sigabort (assert)
Summary: if a node originates more then 512 messages in recovery it will sigabort (ass...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Steven Dake
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: ZStream
: 647291 (view as bug list)
Depends On: 588500
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-04 19:18 UTC by Benjamin Kahn
Modified: 2016-04-26 15:05 UTC (History)
5 users (show)

Fixed In Version: openais-0.80.6-8.el5_4.6
Doc Type: Bug Fix
Doc Text:
In high-loss networks, an assert based on a constant value for the retransmit message queue size could have caused a some nodes to receive SIGABRT signals, and therefore terminate. This constant value has been increased to correspond to the maximum number of entries, thus resolving the issue.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 10:17:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
revision 2129 backported (620 bytes, patch)
2010-05-04 20:15 UTC, Steven Dake
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0485 normal SHIPPED_LIVE openais bug fix update 2010-06-16 10:17:41 UTC

Description Benjamin Kahn 2010-05-04 19:18:32 UTC
This bug has been copied from bug #588500 and has been proposed
to be backported to 5.4 z-stream (EUS).

Comment 3 Steven Dake 2010-05-04 20:15:23 UTC
Created attachment 411398 [details]
revision 2129 backported

Comment 6 errata-xmlrpc 2010-06-16 10:17:49 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0485.html

Comment 7 Steven Dake 2010-12-21 07:11:46 UTC
*** Bug 647291 has been marked as a duplicate of this bug. ***

Comment 8 Douglas Silas 2011-01-11 23:16:54 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
In high-loss networks, an assert based on a constant value for the retransmit message queue size could have caused a some nodes to receive SIGABRT signals, and therefore terminate. This constant value has been increased to correspond to the maximum number of entries, thus resolving the issue.


Note You need to log in before you can comment on or make changes to this bug.