This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 58892 - shutdown -r ==> power off instead of rebooting
shutdown -r ==> power off instead of rebooting
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: basesystem (Show other bugs)
7.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-26 18:10 EST by Richard Elkins
Modified: 2014-03-16 22:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-14 15:43:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Elkins 2002-01-26 18:10:40 EST
Description of Problem:

The issue is in file /etc/init.d/halt.
For "shutdown -r", the resultant $command is "reboot -i -d -p".
But, the "-p" should not be there for a reboot.
I believe that a few lines beginning at 196 in this file 
should be corrected so that only the existence of /poweroff 
causes the appending of "-p".

Version-Release number of selected component (if applicable):


How Reproducible: consistent


Steps to Reproduce:
1. /sbin/shutdown -r now
2. 
3. 

Actual Results: Powered off my PC


Expected Results: 
When /etc/init.d/halt is corrected to check only for
the existence of /poweroff, then my PC 

(a) reboots on `shutdown -r`
(b) power offs on `shutdown`

Additional Information:
n case you think this is hardware related, 
by motherboard is an ABIT BE6.
When I used to run Windows on the same machine,
it differentiated between reboot and shutdown ok.
Note: I am not suggesting that Windoze should be held up 
as a shining example of high-quality hardware operation!
Comment 1 Rik van Riel 2004-10-14 15:43:16 EDT
Looks like this bugzilla fell through the cracks, even though the bug
in question should have been resolved long ago...

Note You need to log in before you can comment on or make changes to this bug.