Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 588926 - Mouse Grabs Wrong Window
Mouse Grabs Wrong Window
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: metacity (Show other bugs)
6.0
i686 Linux
low Severity high
: rc
: ---
Assigned To: Owen Taylor
desktop-bugs@redhat.com
:
Depends On:
Blocks: 599016
  Show dependency treegraph
 
Reported: 2010-05-04 16:13 EDT by Benjamin Bellec
Modified: 2010-11-10 16:10 EST (History)
3 users (show)

See Also:
Fixed In Version: metacity-2.28.0-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 16:10:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 599181 None None None Never

  None (edit)
Description Benjamin Bellec 2010-05-04 16:13:58 EDT
Description of problem:
When maximizing a window by double clicking, then the next window opened is not grab when we want to move it. Instead it's the first window which is grab.

Version-Release number of selected component (if applicable):
RHEL 6 Beta 1 (i386 DVD)

How reproducible:
Each time a window is maximize by double clicking.

Steps to Reproduce:
1. Open a new window (for instance Nautilus)
2. Maximize it by double-clicking on it
3. Open a new window (for instance Terminal)
4. Grab the Terminal to move it on the desktop
  
Actual results:
This is not the correct window which is grab (in that case Nautlius instead of Terminal).

Expected results:
Grab the good window (Terminal in that case).

Additional info:
This entry is a duplication of a know bug on F12/F13 (https://bugzilla.redhat.com/show_bug.cgi?id=533066)
Comment 2 RHEL Product and Program Management 2010-05-04 17:51:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Owen Taylor 2010-05-05 08:37:24 EDT
I'd love to fix this, unfortunately, I've still not reproduced it once, and it's basically impossible for me to fix without being able to reproduce.

The video attached to the Fedora 13 bug is very helpful, *except* that when I do exactly the same sequence of steps I don't reproduce it. :-(
Comment 4 Benjamin Bellec 2010-05-05 09:18:57 EDT
I understand.

What kind of video card (and driver) do you use ? I ask, because (as said in the F13 bug entry) this happend strangly on my two PC (both with radeon driver)... I'm asking on the french fedora forum for have more precision on this track.

Perhaps can you test a LiveF13 on a PC with radeon hardware ?
Comment 5 David Kutálek 2010-05-10 03:24:13 EDT
Hi,

I have same problem on my RHEL 6 laptop.

When I maximize window 1, I tried two ways which both experience this bug:
 - switching to other window using window list on panel, then moving it - moves window 1
 - having laptop screen and external monitor without mirror screen; having window 1 on one display and window 2 on second one, it happens also (moving window 1 on display of window 2...)

My graphics card is some intel one:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 20e4
	Flags: bus master, fast devsel, latency 0, IRQ 28
	Memory at f4400000 (64-bit, non-prefetchable) [size=4M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 1800 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 3
	Kernel driver in use: i915
	Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
	Subsystem: Lenovo Device 20e4
	Flags: bus master, fast devsel, latency 0
	Memory at f4200000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [d0] Power Management version 3

If I can help you to reproduce, feel free to contact me.

David
Comment 6 Benjamin Bellec 2010-05-24 04:26:47 EDT
https://bugzilla.gnome.org/show_bug.cgi?id=599181
Comment 7 David Kutálek 2010-06-01 07:42:15 EDT
By the way, the problem is not only when you try grabbing.
Also click to eg. a close button is sent to wrong window.

David
Comment 8 Benjamin Bellec 2010-06-01 07:54:49 EDT
Of course ! It's just an example.
It occurs also when you want to close a window : that's the wrong window which is closed...
Comment 9 Vladimir Benes 2010-06-01 07:59:35 EDT
hi, I see it also on F13 .. 
nvidia Quadro NVS 3100 
xorg-x11-drv-nouveau-0.0.16-6.20100423git13c1043.fc13.x86_64
Comment 10 Owen Taylor 2010-06-09 16:41:58 EDT
Was able to reproduce, will investigate over the next few days. Details upstream in:

 https://bugzilla.gnome.org/show_bug.cgi?id=599181
Comment 11 Vladimir Benes 2010-06-10 05:22:25 EDT
simple to reproduce via steps in comment #0
qacking
Comment 13 Vladimir Benes 2010-06-30 11:52:02 EDT
works as expected
-> VERIFIED
Comment 14 releng-rhel@redhat.com 2010-11-10 16:10:41 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.