Bug 58894 - kdebase requires qt-devel-2.3.2 to compile
Summary: kdebase requires qt-devel-2.3.2 to compile
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 62000 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-27 00:22 UTC by deniz
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 17:05:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description deniz 2002-01-27 00:22:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011114

Description of problem:
Kdebase Source RPMS require qt-devel-2.3.2 to compile in the recent RH 7.2
update. (kdebase-2.2.2-1.src.rpm).

Qt is still at 2.3.1 and does not have a RH 7.2 update file. 

Will Rawhide work? Will the kdebase binary RPM work with qt-2.3.1?

Best regards,
Deniz

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuild kdebase*
2.
3.
	

Actual Results:  error: failed build dependencies:
        qt-devel >= 2.3.2 is needed by kdebase-2.2.2-1

Expected Results:  Should have compiled and not depended on a package not yet
published?



Additional info:

Comment 1 Ben Levenson 2002-01-28 16:33:43 UTC
I must not have properly cleaned up the test system after the
qt-2.3.2 RPMs were yanked from 
the original errata request...
bero - Is it sufficient to edit the spec file, rev down the qt-devel
build-
req, and then try to build from source?

Comment 2 Ben Levenson 2002-03-26 17:29:43 UTC
*** Bug 62000 has been marked as a duplicate of this bug. ***

Comment 3 Tim Powers 2002-03-26 17:39:09 UTC
you didn't do anything wrong in the buildroots, he has a hardcoded requirement
for that version of qt in kdebase. How this made it out as an errata is an
unknown at this point. This effects Pensacola as well.

Tim

Comment 4 Ben Levenson 2002-03-27 17:05:04 UTC
ummm... Unfortunately, I did pollute the buildroot of the test box. 
The original KDE errata request included a newer version of qt. The qt RPMs 
were yanked once I found a couple of bugs with them. Unfortunately, I failed
to properly clean them from the test system before I resumed the source rebuilds.
my mistake here...

Comment 5 Harald Hoyer 2002-08-05 12:53:27 UTC
Please reopen, if this is still an issue.
Thx,
Harald


Note You need to log in before you can comment on or make changes to this bug.