Bug 588959 - regression: neon does not work with SNI, patched upstream
regression: neon does not work with SNI, patched upstream
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: neon (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 19:19 EDT by Felix Möller
Modified: 2010-11-09 20:13 EST (History)
2 users (show)

See Also:
Fixed In Version: neon-0.29.5-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-09 20:13:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 569639 None None None Never

  None (edit)
Description Felix Möller 2010-05-04 19:19:59 EDT
Description of problem:
I have a subversion server which serves with mod_dav. I have my apache configured with name based virtual hosts. They work perfectly with a browser. Sadly on doing svn up the wrong certificate is polled from the server. As sni is not used.

This has been reported at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=569639 and has been fixed upstream at http://lists.manyfish.co.uk/pipermail/neon-commits/2010-March/000872.html.

Version-Release number of selected component (if applicable):
neon-0.29.3-1.fc13.i686
subversion-1.6.9-2.fc13.i686

How reproducible:
100%

Steps to Reproduce:
1. setup mod_dav_svn
2. setup name based virtual hosting
3. do svn co on such a host
  
Actual results:
wrong certificate chosen

Expected results:
right certificate
Comment 1 Felix Möller 2010-05-05 12:36:07 EDT
Add Ville Skyttä who seems to be working on subversion.
Comment 2 Joe Orton 2010-05-05 12:40:22 EDT
I've merged this fix to the neon 0.29.x branch upstream and will try to wrap up a new release soon.
Comment 3 Felix Möller 2010-05-25 06:22:42 EDT
The relevant commit is at http://lists.manyfish.co.uk/pipermail/neon-commits/2010-May/000878.html

Any chance to get this pushed out as an update?
Comment 4 Felix Möller 2010-07-17 10:31:56 EDT
somehow used wrong component
Comment 5 Felix Möller 2010-07-28 10:38:45 EDT
I am running F14 now.
Comment 6 Fedora Update System 2010-10-05 05:46:14 EDT
neon-0.29.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/neon-0.29.4-1.fc14
Comment 7 Fedora Update System 2010-10-05 17:49:33 EDT
neon-0.29.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update neon'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/neon-0.29.4-1.fc14
Comment 8 Fedora Update System 2010-10-17 11:42:37 EDT
neon-0.29.5-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update neon'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/neon-0.29.5-1.fc14
Comment 9 Fedora Update System 2010-11-09 20:13:29 EST
neon-0.29.5-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.