Bug 588961 - [abrt] crash in setroubleshoot-server-2.2.77-2.fc13: browser.py:484:quit:IndexError: list index out of range
Summary: [abrt] crash in setroubleshoot-server-2.2.77-2.fc13: browser.py:484:quit:Inde...
Status: CLOSED DUPLICATE of bug 591023
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a55bdef3
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-04 23:23 UTC by Christoph Wickert
Modified: 2010-05-11 14:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-11 09:13:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (757 bytes, text/plain)
2010-05-04 23:23 UTC, Christoph Wickert
no flags Details

Description Christoph Wickert 2010-05-04 23:23:43 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python -E /usr/bin/sealert -s
comment: Sealert crashed when I closed it.
component: setroubleshoot
executable: /usr/bin/sealert
kernel: 2.6.33.3-72.fc13.x86_64
package: setroubleshoot-server-2.2.77-2.fc13
reason: browser.py:484:quit:IndexError: list index out of range
release: Fedora release 13 (Goddard)

backtrace
-----
browser.py:484:quit:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/setroubleshoot/browser.py", line 484, in quit
    while self.current_alert > 0 and self.alert_list[self.current_alert].local_id in self.do_not_notify_list:
IndexError: list index out of range

Local variables in innermost frame:
widget: <gtk.Button object at 0x26dcbe0 (GtkButton at 0x1c9acb0)>
self: <setroubleshoot.browser.BrowserApplet instance at 0x26dbf38>
l: 3
alert: <setroubleshoot.signature.SEFaultSignatureInfo object at 0x42996d0>
saved_id: ''
file: <open file '/home/chris/.setroubleshoot', mode 'w' at 0x2a11470>
filename: '/home/chris/.setroubleshoot'
id: 'bb9694a9-03d8-4754-a1ea-f3bca9b4d71a'
first: False

How to reproduce
-----
1. mark some alarms to be ignored
2. tray icon informs you of alerts, but the sealert window is empty
3. close the window with the 'close' button and it crashes

Comment 1 Christoph Wickert 2010-05-04 23:23:46 UTC
Created attachment 411430 [details]
File: backtrace

Comment 2 Christoph Wickert 2010-05-11 09:13:54 UTC
We still have the same problem but with a newer version of setroubleshoot, so let's use the new backtrace.

*** This bug has been marked as a duplicate of bug 591023 ***

Comment 3 Fedora Update System 2010-05-11 14:51:23 UTC
setroubleshoot-2.2.83-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/setroubleshoot-2.2.83-1.fc13


Note You need to log in before you can comment on or make changes to this bug.