Bug 588981 - SELinux is preventing /usr/bin/python "sys_tty_config" access .
SELinux is preventing /usr/bin/python "sys_tty_config" access .
Status: CLOSED DUPLICATE of bug 588563
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:78bdd10c72f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 22:15 EDT by John Mellor
Modified: 2010-05-11 12:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 05:13:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mellor 2010-05-04 22:15:33 EDT
Summary:

SELinux is preventing /usr/bin/python "sys_tty_config" access .

Detailed Description:

[denyhosts.py has a permissive type (denyhosts_t). This access was not denied.]

SELinux denied access requested by denyhosts.py. It is not expected that this
access is required by denyhosts.py and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:denyhosts_t:s0
Target Context                system_u:system_r:denyhosts_t:s0
Target Objects                None [ capability ]
Source                        denyhosts.py
Source Path                   /usr/bin/python
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.6.2-4.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-113.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.32.11-99.fc12.i686.PAE #1 SMP Mon Apr 5
                              16:15:03 EDT 2010 i686 athlon
Alert Count                   4
First Seen                    Mon 03 May 2010 09:42:50 PM EDT
Last Seen                     Mon 03 May 2010 09:42:51 PM EDT
Local ID                      daea05a8-3659-46d3-9567-d6a768ea6ff5
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1272937371.358:10): avc:  denied  { sys_tty_config } for  pid=1517 comm="denyhosts.py" capability=26  scontext=system_u:system_r:denyhosts_t:s0 tcontext=system_u:system_r:denyhosts_t:s0 tclass=capability

node=(removed) type=SYSCALL msg=audit(1272937371.358:10): arch=40000003 syscall=54 success=yes exit=0 a0=2 a1=5401 a2=bfafd918 a3=bfafd958 items=0 ppid=1516 pid=1517 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="denyhosts.py" exe="/usr/bin/python" subj=system_u:system_r:denyhosts_t:s0 key=(null)



Hash String generated from  catchall,denyhosts.py,denyhosts_t,denyhosts_t,capability,sys_tty_config
audit2allow suggests:

#============= denyhosts_t ==============
allow denyhosts_t self:capability sys_tty_config;
Comment 1 Miroslav Grepl 2010-05-05 05:13:09 EDT

*** This bug has been marked as a duplicate of bug 588563 ***

Note You need to log in before you can comment on or make changes to this bug.