Bug 58900 - xgamma does not change the gamma value
xgamma does not change the gamma value
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-27 04:19 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-06 04:16:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration File for XFree86 (Chipset i810 + Gateway Vivitron) (5.31 KB, text/plain)
2002-02-03 05:24 EST, Need Real Name
no flags Details
XFree86 Start log file (19.90 KB, text/plain)
2002-02-03 05:26 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-01-27 04:19:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; DVD Owner)

Description of problem:
I want to change the Gamma value used on my monitor, to get more natural colors.
The xgamma program is supposed to be used for that purpose.
But, when I try this command, I get:
xgamma ------------> Returns the current value (1.0 for RGB),
xgamma -gamma 1.8 -> Returns the current value and try to set 1.0 as the new 
value.
I have tried integer values, like 2, tried under root, tried to set R, G & B 
separately. Nothing works.
My Monitor is a Gateway Vivitron 1572,
The video card is the Intel i810 Chipset, with the proper driver (not the new 
Intel driver provided on support.intel.com),
The setting is 1024 x 768 x 24b.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start a console terminal from the KDE windows, for instance.
2. Use xgamma to get the current value.
3. Use xgamma -gamma "new_value", where "new_value" is a value which is 
different from the current value, but not far to avoid any problem of not valid 
value.
	

Actual Results:  The screen remains unchanged.
The value in front of the signs <- and -> are 1.0.

Expected Results:  The gamma factor should be adjusted.

Additional info:

If you could give me the way to preset the value at boot time, it would be 
great.
Thanks.
Comment 1 Mike A. Harris 2002-01-27 22:54:15 EST
Do any errors or warnings appear in your X server log file?

You may want to set the Gamma inyour config file instead.

man XF86Config  might help
Comment 2 Need Real Name 2002-01-30 14:51:21 EST
I have regenerated the XF86Config-4 file, first using xconfigurator, then 
modifying it manually.
I have added the gamma correction I want, and it is accepted by the driver.
But the xgamma command still does not change anything.
Note that the xvidtune option is not disallowed.
I do not have any error message for the xgamma command in /var/log/X*.log (the 
messages I have are for modes automatically tested by the i810 driver and that 
are not supported by the monitor or that are removed because I have truncated 
the virtual size to 1024x768).
Comment 3 Mike A. Harris 2002-01-31 19:12:06 EST
Which XFree86 release are you using:

rpm -qa | grep XFree86
Comment 4 Mike A. Harris 2002-01-31 19:19:37 EST
ALso, please attach your config file, and also your XFree86 server log
using the attachment link below.
Comment 5 Need Real Name 2002-02-03 05:24:35 EST
Created attachment 44377 [details]
Configuration File for XFree86 (Chipset i810 + Gateway Vivitron)
Comment 6 Need Real Name 2002-02-03 05:26:19 EST
Created attachment 44378 [details]
XFree86 Start log file
Comment 7 Need Real Name 2002-02-03 05:33:48 EST
I have added the conf & log files for XFree86, including the XFree86 version  
(4.0.3).
It seems that, even if we find "Using gamma correction 1.9" in the log file, it 
is not supported by the driver. It could, so, explain why it is unchanged by 
the xgamma program (but an more explicit error/warning message should be 
issued).
On the XFree86 web site, the new i810 driver does not seem to support this 
option even today. I do not know how to make an "Enhancement request".
On the Intel support web site, we can find an agp module and an i810 driver, 
but I do not know if it is better or not.
Comment 8 Need Real Name 2002-02-03 05:36:08 EST
Even if it is not the same problem (not a bug), but since it is close to what 
you are working on, any idea about "DRI disabled" at the end of the file would 
be appreciated.
Thanks.
Comment 9 Need Real Name 2002-02-06 04:15:40 EST
I think you can close the call, provided to forward a request of either change 
the documentation or develop some more lines of code...
THE GAMMA CORRECTION ONLY WORKS WORK A DEPTH OF 8 BITS !
IT DOES NOT WORK WITH 16 BITS OR 24 BITS.

Extra information: The DRI module only seems to work in 16 bits (not in 8 nor 
24) !

For the Gamma correction, I do not understand why it does not work in 24 bits, 
because it is hardware-supported by the chipset.

Thanks + Bye.
Comment 10 Mike A. Harris 2002-03-11 01:42:20 EST
These features that are missing are something you should request of
XFree86.org to add support for, or to Intel directly.  They are not
really bugs, just missing features.

DRI only works on i810 at 16bit depth because that is all the hardware
supports.

Note You need to log in before you can comment on or make changes to this bug.