Bug 58901 - kudzu permanently asks for hardware change
kudzu permanently asks for hardware change
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-27 04:35 EST by Need Real Name
Modified: 2014-03-19 07:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 17:44:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add support for intermittently connected devices to kudzu (16.49 KB, patch)
2003-03-28 11:02 EST, Ron Yorston
no flags Details | Diff
Improved patch for intermittently connected devices (5.00 KB, patch)
2003-03-29 14:40 EST, Ron Yorston
no flags Details | Diff

  None (edit)
Description Need Real Name 2002-01-27 04:35:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; DVD Owner)

Description of problem:
I have an external Scanner, which is sometimes powered On or Off.
When the system is booted many times, with the scanner alternatively powered on 
or off, kudzu asks if the description should be kept/removed even if we 
previously have answered it should be kept.
In other words, when kudzu recognizes the scanner (after a power on and a 
reboot), it forget we have requested to keep the description and, when powered 
off, we are again asked if the description should be kept or removed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Connect an external deviceto the system (for instance a scanner).
2. Switch on the device and boot the system -> Kudzu recognizes the device.
3. Switch off the device and reboot -> Kudzu asks if the device description 
must be kept or removed ; ANSWER IT SHOULD BE KEPT.
4. Switch on the device and reboot -> Kudzu recognizes the device and uses the 
old description.
5. Switch off the device and reboot -> BUG !

Actual Results:  Kudzu asks again if the description must be kept or removed.
This is really more than boring for such a peripheral, that is on one day, and 
off the day after (to avoid mechanical problems due to multiple reset).

Expected Results:  Kudzu should remember that we have previously requested the 
description to be kept.
Like fsck, we should have a counter for how many system boots the software 
should wait before asking again if the description must be removed (otherwise, 
we won't be able to ever removed the description).

Additional info:
Comment 1 Ron Yorston 2002-04-26 07:52:35 EDT
I find the same problem with external mice attached to laptops.  Once I've got
the system configured as I want it I'd like kudzu to stop pestering me every
time it notices that the external mouse has been reconnected.  As well as being
irritating there's the danger that a user who isn't in on the secret will chose
the wrong option and cause kudzu to rewrite (and break) the X configuration.
Comment 2 Mark Wilkinson 2003-03-11 05:58:14 EST
I'd find this change useful too, both for my laptop and my desktop machine.

For my laptop I have a USB mouse, USB floppy and PCMCIA CD-ROM and PCMCIA
network/modem card. Some of these might not be connected when I turn the laptop
on, hence I get the warning from kudzu that a device has disappeared. Things
have improved over time as handling of hot-swap devices has improved, but the
USB mouse still causes the problem from what I remember.

My desktop machine has the same problem - the modem is used infrequently so I
often don't switch it on when the machine is booting, leading to kudzu prompting
again on the first boot with the modem switched off, then the first boot with it
switched on, etc.

It would be useful to have a 'This device is intermittently connected. Never ask
me about it at boot time' check box to overcome this.
Comment 3 Ron Yorston 2003-03-28 11:02:34 EST
Created attachment 90764 [details]
Add support for intermittently connected devices to kudzu

I've implemented support for intermittently connected devices in kudzu.  The
new kudzu has been minimally tested on my laptop and it successfully handles my
USB mouse:  whether or not it's connected at boot time the configuration stays
put.
Comment 4 Bill Nottingham 2003-03-28 11:07:26 EST
Hm, I think what needs to be done here is to just *fix* the 'detached' flag so
that it works, not to implement new variations on it.
Comment 5 Ron Yorston 2003-03-29 14:40:36 EST
Created attachment 90789 [details]
Improved patch for intermittently connected devices

Bill is right, my previous patch was much too complicated.  Here's a simpler
one.  I don't have the USB mouse to hand so this has been tested with a serial
mouse.	All the combinations I can think of seem to work as I'd like.
Comment 6 Bill Nottingham 2005-02-04 17:44:17 EST
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response. Please attempt to confirm with more recent releases.

Note You need to log in before you can comment on or make changes to this bug.