Bug 589019 - systems forgets local users after a while
systems forgets local users after a while
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.9
All Linux
low Severity medium
: rc
: ---
Assigned To: Jeff Law
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 02:48 EDT by Rik Theys
Modified: 2016-11-24 10:37 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-26 12:08:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik Theys 2010-05-05 02:48:23 EDT
Description of problem:

The system is configured to use files and ldap as sources for passwd and group.
After a while (sometimes a few days, sometimes months) the system seems to forget about the local users causing all sorts of breakage.

When that happens, local users and ldap users can no longer log in remotely using ssh (because the sshd privilege user can not be found). Local users can NOT log in on the console as they are not known. LDAP users can log in on the console.

When nscd is not running, logging in as an LDAP user on the console unblocks everything and local users are known again after that.

When nscd is running, local users remain unknown after logging in as an LDAP user on the console. Running 'getent passwd' returns entries from both /etc/passwd and ldap, but running 'getent passwd root' returns nothing.

This happens on systems running nscd and systems not running nscd.


Version-Release number of selected component (if applicable):

We are seeing this behaviour on RHEL4:
 kernel-smp-2.6.9-89.0.23.EL
 glibc-2.3.4-2.43.el4_8.2.x86_64

And also on RHEL5 (CentOS 5):
 kernel-2.6.18-164.15.1.el5
 glibc-2.5-42.el5_4.3.x86_64

And also on Debian Lenny:
 kernel 2.6.26-2-amd64
 libc6 2.7-18lenny2

The only common factor seems to be x86_64.

How reproducible:

Issue was extremely rare in the past (once a year), but has gotten a lot more frequent lately (3 times in 2 weeks, on different systems).

Steps to Reproduce:
1.
2.
3.
  
Actual results:

system forgets users from /etc/passwd after a while

Expected results:

system keeps parsing /etc/passwd and doesn't forget users.

Additional info:
Comment 1 Jeff Law 2012-01-26 12:08:24 EST
This was reported against Red Hat Enterprise Linux 4 and we are not planning to address the problem in that release.  However, there may be a workaround you can try.  Specifically set threads and max_threads to 1 in /etc/nscd.conf.

Note You need to log in before you can comment on or make changes to this bug.