Bug 589033 - Cannot convert kvm-rhel39 with PAE kernel [NEEDINFO]
Summary: Cannot convert kvm-rhel39 with PAE kernel
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: augeas   
(Show other bugs)
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-05 07:47 UTC by Rita Wu
Modified: 2014-06-02 13:23 UTC (History)
6 users (show)

Fixed In Version: 0.7.1-1.el5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 13:23:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (rwu)


Attachments (Terms of Use)
grub.conf in guest (427.89 KB, image/png)
2010-05-05 07:47 UTC, Rita Wu
no flags Details
log from virt-inspect before conversion (232.64 KB, text/plain)
2010-05-06 05:32 UTC, Rita Wu
no flags Details
log during conversion from LIBGUESTFS_TRACE=1 (2.39 KB, text/plain)
2010-05-06 05:33 UTC, Rita Wu
no flags Details
grub.conf got from the original guest before conversion (763 bytes, application/octet-stream)
2010-05-07 06:54 UTC, Rita Wu
no flags Details

Description Rita Wu 2010-05-05 07:47:48 UTC
Created attachment 411503 [details]
grub.conf in guest

Description of problem:
Cannot convert kvm-rhel39 with PAE kernel

Version-Release number of selected component (if applicable):
virt-v2v-0.5.2-1.el5
v2v-libvirt-0.8.0-2.el5


How reproducible:
100%

Steps to Reproduce:
Converting image : /media/disk-1/cleankvm/raw/cleankvm-RHEL-3.9-PAE.raw
Domain cleankvm-RHEL-3.9-PAE.raw defined from /tmp/cleankvm-RHEL-3.9-PAE.raw.xml

virt-v2v -f /usr/share/doc/virt-v2v-0.5.2/virt-v2v.conf -o rhev -osd 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/export cleankvm-RHEL-3.9-PAE.raw
Use of uninitialized value in string eq at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/GuestOS/RedHat.pm line 406.
Use of uninitialized value in string eq at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/GuestOS/RedHat.pm line 406.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Config.pm line 262.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Config.pm line 262.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Config.pm line 262.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Config.pm line 262.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Config.pm line 262.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Config.pm line 262.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/Config.pm line 184.
virt-v2v: No app in config matches distro='rhel' name='' major='3' minor='9' arch='i686'
virt-v2v: No bootable kernels installed, and no replacement specified in configuration.
Unable to continue.
virt-v2v: Failed to unmount 10.66.90.115:/vol/v2vwulinglu/wulingluv2v/export. Command exited with status 1. Output was: umount: /tmp/QGKcqa8w8S: device is busy
umount: /tmp/QGKcqa8w8S: device is busy

virt-v2v: Failed to remove mount directory /tmp/QGKcqa8w8S: Device or resource busy
  
Actual results:
fail to convert

Expected results:
convert succesfully

Additional info:

Comment 1 Matthew Booth 2010-05-05 13:28:38 UTC
Linglu,

Could you please attach the output of:

virt-inspector --perl /path/to/disk/image

Could you please run this against the guest *before* conversion.

Thanks,

Matt

Comment 2 Matthew Booth 2010-05-05 14:23:44 UTC
This:

Use of uninitialized value in string eq at
/usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/GuestOS/RedHat.pm line 406.

Suggests that there were no configs in the virt-inspector output. This isn't right, as the attached grub.conf shows configurations which should have been picked up.

I've pushed a patch upstream which moves the default kernel name setting out of the configs loop. This fix is likely to make this particular issue go away, however the underlying cause still needs to be investigated.

Comment 3 Rita Wu 2010-05-06 05:32:43 UTC
Created attachment 411820 [details]
log from virt-inspect before conversion

Comment 4 Rita Wu 2010-05-06 05:33:58 UTC
Created attachment 411821 [details]
log during conversion from LIBGUESTFS_TRACE=1

Comment 5 Matthew Booth 2010-05-06 09:51:52 UTC
And indeed, configs is empty in the virt-inspector output. Could you please attach:

1. The version of augeas-libs installed on the conversion host
2. The contents of grub.conf in the guest prior to conversion

Thanks,

Matt

Comment 6 Rita Wu 2010-05-06 11:09:09 UTC
(In reply to comment #5)
> And indeed, configs is empty in the virt-inspector output. Could you please
> attach:
> 
> 1. The version of augeas-libs installed on the conversion host
> 2. The contents of grub.conf in the guest prior to conversion
> 
> Thanks,
> 
> Matt    

1.# rpm -qa|grep augea
augeas-libs-0.7.0-1.el5
2.pls see the attachment below

Comment 7 Rita Wu 2010-05-07 06:54:31 UTC
Created attachment 412247 [details]
grub.conf got from the original guest before conversion

Comment 8 Matthew Booth 2010-05-07 15:59:29 UTC
Thanks, Linglu.

This is a problem with the augeas lens: it doesn't like the commented out initrd.

Comment 9 Matthew Booth 2010-05-10 15:44:01 UTC
Could you please update augeas-libs on the conversion box to augeas-libs-0.7.1-1.el5.2?

Comment 10 Rita Wu 2010-05-11 09:39:33 UTC
(In reply to comment #9)
> Could you please update augeas-libs on the conversion box to
> augeas-libs-0.7.1-1.el5.2?   

After updating to augeas-libs-0.7.1-1.el5.2. RHEL39 with PAE kernel can be converted.

Comment 11 cshao 2010-09-15 05:20:34 UTC
I test this bug in version virt-v2v-0.6.1-2.el5, now RHEL39 with PAE kernel can be
converted successful.

#virt-v2v -i libvirtxml -o rhev -osd 10.66.90.115:/vol/v2vrwu2/esx_export rhel39-pae-raw-el5.xml
open /dev/kvm: No such file or directory
Could not initialize KVM, will disable KVM support
unknown filesystem /dev/fd0
virt-v2v: No capability in config matches os='linux' name='virtio' distro='rhel' major='3' minor='9'
virt-v2v: WARNING: No mapping found for bridge interface breth0 in config file. The converted guest may not start until its network interface is updated.
virt-v2v: rhel39-pae-raw-el5 configured without virtio drivers

Comment 14 RHEL Product and Program Management 2014-03-07 13:56:29 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 15 RHEL Product and Program Management 2014-06-02 13:23:34 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.