Bug 58904 - No Multi-Lun support
No Multi-Lun support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-27 10:03 EST by Bill Stephens
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-11 16:41:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Stephens 2002-01-27 10:03:23 EST
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Have a Tape autoloader
2. Install Kernel Errata
3. Try to use a multi Lun SCSI Device

Actual Results:
Only the first lun device is reported

Expected Results:
All LUN devices should be reported and available.

Additional Information:
You don't have the multi-lun option turned on when you compile your stock 
kernels.  If I turn it on in your source config files, rebuild the kernel 
package, install the fixed pakcages, everything works fine.
Comment 1 Arjan van de Ven 2002-01-27 10:10:33 EST
Multi-lun unfortionatly cannot be turned on by default since quite a few (cheap)
scsi devices break that way. There's 2 things that can be done:

1) add the line
options scsi_mod max_scsi+luns=128
to the /etc/modules.conf file and then regenerate the initrd

or 
2) get me the output of cat /proc/scsi/scsi so that your scsi device can be
added to the whitelist of devices where the kernel DOES scan all luns
Comment 2 Bill Stephens 2002-01-28 07:40:31 EST
The output from my /proc/scsi/scsi:
Host: scsi0 Channel: 00 Id: 05 Lun: 00
  Vendor: HP       Model: C1557A           Rev: U709
  Type:   Sequential-Access                ANSI SCSI revision: 02

Couldn't you just:
3. Select CONFIG_SCSI_MULTI_LUN=y in your kernel config?  

Multi LUN's worked in 7.0.  Any reason they stopped?
Comment 3 Bill Stephens 2002-01-28 07:48:05 EST
Dooh, not enough coffee yet.  I just ready your response why you can't turn it 
back on.  Sounds like a damned if you do damned if you don't scenario.  Either 
way stuff gets broken.
Comment 4 Arjan van de Ven 2002-01-28 07:51:24 EST
Unfortionatly yes ;(
Thanks for the whitelist entry; I'll add it so it should just work for newer
kernels
Comment 5 Arjan van de Ven 2002-02-11 12:26:06 EST
Added the entry.
Does the option work or should I give more details on how to do it?
Comment 6 Bill Stephens 2002-02-11 13:07:57 EST
More details please.  I'm not sure what or how to test.
Comment 7 Arjan van de Ven 2002-02-11 13:11:51 EST
1) add the line
options scsi_mod max_scsi+luns=128
to /etc/modules.conf

2) rm /boot/initrd-2.4.9-21smp.img
3) mkinitrd /boot/initrd-2.4.9-21smp.img 2.4.9-21smp

reboot

that ought to do it (assuming the smp kernel)
Comment 8 Bill Stephens 2002-02-11 16:41:40 EST
That worked fine.  Thanks
Comment 9 Arjan van de Ven 2002-02-11 16:47:31 EST
Ok, ID added, your machine works.... I'm going to close this as "Fixed Current
release" as that's closest of what it realy is. If you object to closing this
bug, please reopen.

Note You need to log in before you can comment on or make changes to this bug.