Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 589059 - Xen pvops kernel storage backend stats location changed
Xen pvops kernel storage backend stats location changed
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 05:29 EDT by Adi Kriegisch
Modified: 2016-03-20 20:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-20 20:09:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix block_stats for xen/pvops kernel (726 bytes, patch)
2010-05-05 05:29 EDT, Adi Kriegisch
no flags Details | Diff

  None (edit)
Description Adi Kriegisch 2010-05-05 05:29:42 EDT
Created attachment 411526 [details]
fix block_stats for xen/pvops kernel

As stated in http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=1454 "/sys/devices/xen-backend/" changed to "/sys/bus/xen-backend/".
Therefor libvirt (virsh, virt-manager, ...) are unable to report storage backend performance numbers. This seems to be true for all new Xen pv-ops kernels (2.6.3X)
The attached patch tries to fix this by appending that path to "read_bd_stat" in "src/xen/block_stats.c".
Comment 1 Cole Robinson 2016-03-20 20:09:29 EDT
Sorry this patch was never reviewed...  a similar patch was eventually applied upstream:

commit 8a70113a9949fd482151f2962dd760364525a996
Author: Guido Günther <agx@sigxcpu.org>
Date:   Fri Sep 10 15:57:35 2010 +0200

    Fix block statistics with newer versions of Xen

Note You need to log in before you can comment on or make changes to this bug.