Bug 589087 - sbcl update broke maxima
sbcl update broke maxima
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: maxima (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 07:21 EDT by nucleo
Modified: 2010-05-26 17:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: pvs-sbcl-4.2-4.20100126svn.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 17:48:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2010-05-05 07:21:32 EDT
Description of problem:
maxima not works after update to sbcl-1.0.35-3.fc12

Version-Release number of selected component (if applicable):
maxima-5.20.1-3.fc12.i686

Steps to Reproduce:
1. Start maxmia
  
Actual results:
fatal error encountered in SBCL pid 4627(tid 3084895936):
can't load .core for different runtime, sorry

Additional info:
maxima works after downgrading to sbcl-1.0.35-1.fc12
Comment 1 Fedora Update System 2010-05-10 15:55:32 EDT
pvs-sbcl-4.2-4.20100126svn.fc12,maxima-5.20.1-4.fc12,sbcl-1.0.38-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/pvs-sbcl-4.2-4.20100126svn.fc12,maxima-5.20.1-4.fc12,sbcl-1.0.38-2.fc12
Comment 2 Fedora Update System 2010-05-11 15:45:06 EDT
pvs-sbcl-4.2-4.20100126svn.fc12, maxima-5.20.1-4.fc12, sbcl-1.0.38-2.fc12, wxMaxima-0.8.5-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pvs-sbcl maxima sbcl wxMaxima'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wxMaxima-0.8.5-1.fc12,pvs-sbcl-4.2-4.20100126svn.fc12,maxima-5.20.1-4.fc12,sbcl-1.0.38-2.fc12
Comment 3 mokeny 2010-05-12 16:11:54 EDT
(In reply to comment #2)
> pvs-sbcl-4.2-4.20100126svn.fc12, maxima-5.20.1-4.fc12, sbcl-1.0.38-2.fc12,
> wxMaxima-0.8.5-1.fc12 has been pushed to the Fedora 12 testing repository.  If
> problems still persist, please make note of it in this bug report.
>  If you want to test the update, you can install it with 
>  su -c 'yum --enablerepo=updates-testing update pvs-sbcl maxima sbcl wxMaxima'.
>  You can provide feedback for this update here:
> http://admin.fedoraproject.org/updates/wxMaxima-0.8.5-1.fc12,pvs-sbcl-4.2-4.20100126svn.fc12,maxima-5.20.1-4.fc12,sbcl-1.0.38-2.fc12    

This works for me, but I should also check that can run,  maxima-gui without the same issue. But am unable to due to dependencies.
Comment 4 Dom Layfield 2010-05-17 19:31:06 EDT
I encountered the same bug.  Revised packages in updates-testing work for me.  Thanks for the fix!
Comment 5 Fedora Update System 2010-05-26 17:48:23 EDT
pvs-sbcl-4.2-4.20100126svn.fc12, maxima-5.20.1-4.fc12, sbcl-1.0.38-2.fc12, wxMaxima-0.8.5-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.