Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 589088 - AttributeError: 'Anaconda' object has no attribute 'protected'
Summary: AttributeError: 'Anaconda' object has no attribute 'protected'
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:ef13b613d727a86ea...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-05 11:22 UTC by Bojan Smojver
Modified: 2010-05-05 12:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-05 12:28:25 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (94.40 KB, text/plain)
2010-05-05 11:22 UTC, Bojan Smojver
no flags Details

Description Bojan Smojver 2010-05-05 11:22:14 UTC
The following was filed automatically by anaconda:
anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/tmp/updates/storage/__init__.py", line 88, in storageInitialize
    if anaconda.protected:
  File "/tmp/updates/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/tmp/updates/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/tmp/updates/gui.py", line 1401, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/tmp/updates/gui.py", line 1314, in nextClicked
    self.setScreen ()
AttributeError: 'Anaconda' object has no attribute 'protected'

Comment 1 Bojan Smojver 2010-05-05 11:22:19 UTC
Created attachment 411547 [details]
Attached traceback automatically from anaconda.

Comment 2 Michal Schmidt 2010-05-05 11:55:05 UTC
It may an actual bug in anaconda, but it also may be caused by the medium errors (unrecovered read errors) while reading from /dev/sr0 as reported in the log.

Comment 3 Hans de Goede 2010-05-05 12:28:25 UTC
This bug is caused by using an updates.img meant to be used with TC1 with the beta.


Note You need to log in before you can comment on or make changes to this bug.