Bug 589089 - ABRT 1.1.0 is appearing to hang when attempting to get debug packages
ABRT 1.1.0 is appearing to hang when attempting to get debug packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 07:23 EDT by Place Holder
Modified: 2015-02-01 17:51 EST (History)
8 users (show)

See Also:
Fixed In Version: abrt-2.0.1-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-26 12:20:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Place Holder 2010-05-05 07:23:12 EDT
Description of problem:
I have an bug report outstanding in ABRT that I want to report.  Its from Firefox.  When I click on it, click report, it brings up a window saying its looking for 94 additional debug symbols and then appears to hang.  I left it for 12 hours with no change.  I just closed ABRT and reopened it, and now that window is not even populating with any text in the details section and the progress bar is just cycling.

Version-Release number of selected component (if applicable):
1.1.0

How reproducible:
Has happened twice (before and after a reboot.)

Steps to Reproduce:
1.  Attempt to report a bug when not all debug info's are on system.
  
Actual results:
Can't report the bug, even with missing debug info, because ABRT never seems to time out at whatever its doing.

Expected results:
Expect to be able to report bugs/crashes.

Additional info:
Fedora 13 Beta with all available patches applied.
Comment 1 Place Holder 2010-05-05 07:37:46 EDT
I just tried to check for updated packages, and its hung waiting on the yum lock...

Perhaps this is a yum/packagekit issue?

$ps -ef | grep -i abrt
nick       336   306  0 07:35 pts/2    00:00:00 grep -i abrt
root      1617     1  0 May04 ?        00:00:00 /usr/sbin/abrtd
nick      2145  1908  0 May04 ?        00:00:00 abrt-applet
root      2727  1617  0 May04 ?        00:00:00 /bin/sh /usr/bin/abrt-debuginfo-install /var/cache/abrt/ccpp-1273000238-2318/coredump /var/run/abrt/tmp-2727-1273012293 /var/cache/abrt-di
root      2757  2727  0 May04 ?        00:00:00 /bin/sh /usr/bin/abrt-debuginfo-install /var/cache/abrt/ccpp-1273000238-2318/coredump /var/run/abrt/tmp-2727-1273012293 /var/cache/abrt-di
root      2759  2757  0 May04 ?        00:00:00 /bin/sh /usr/bin/abrt-debuginfo-install /var/cache/abrt/ccpp-1273000238-2318/coredump /var/run/abrt/tmp-2727-1273012293 /var/cache/abrt-di

$ ps -ef | grep -i yum
root       303   302  0 07:33 ?        00:00:00 /usr/bin/python /usr/share/PackageKit/helpers/yum/yumBackend.py get-updates newest
nick       338   306  0 07:35 pts/2    00:00:00 grep -i yum
root      2760  2759  0 May04 ?        00:00:07 /usr/bin/python /usr/bin/yum --disablerepo=* --enablerepo=fedora-debuginfo* --enablerepo=google-chrome-debuginfo* --enablerepo=rpmfusion-free-debuginfo* --enablerepo=rpmfusion-free-updates-debuginfo* --enablerepo=rpmfusion-nonfree-debuginfo* --enablerepo=rpmfusion-nonfree-updates-debuginfo* --enablerepo=updates-testing-debuginfo* --showduplicates --quiet provides /usr/lib/debug/.build-id/01/d500ca8108b1bcfa8ee35583507a07cc8c9447.debug /usr/lib/debug/.build-id/03/4bb9208972bee6f2fc2f1d04624d95e336468c.debug /usr/lib/debug/.build-id/03/e3ef595b697e02a1c8f280e8387e3daadf53db.debug /usr/lib/debug/.build-id/06/d8d77becfb4505090aa9cd5b84d09510f8512a.debug /usr/lib/debug/.build-id/07/a3723d52f6b950a85909d1ae5dbee2d6bdb262.debug /usr/lib/debug/.build-id/0a/fdfc236fadadc174323855991e9afa63360400.debug /usr/lib/debug/.build-id/0c/8e22e58d8c3b881e8c66baf4f98a6784c16198.debug /usr/lib/debug/.build-id/12/83490e69e5825cde51e82628620a9f9f6954a8.debug /usr/lib/debug/.build-id/14/c259a0bb45ee7239b4f6259db06690d13deea1.debug /usr/lib/debug/.build-id/17/fd2438d720e0d593860526127038f8e8b1a590.debug /usr/lib/debug/.build-id/18/348684e03e1e86a1abfc97d2c7d617fbd735c7.debug /usr/lib/debug/.build-id/1a/b7aaaddf86886de11b3e59285489570ff211fe.debug /usr/lib/debug/.build-id/1b/ace9f231e5b95660a1e08ae5412b129c7ddaa6.debug /usr/lib/debug/.build-id/23/8cd6323691f20d2bccd536b772c88a7ad7388e.debug /usr/lib/debug/.build-id/25/36190aa4dfa3be852e189f316aadcb89046c7a.debug /usr/lib/debug/.build-id/25/cb61f69562cd18796feff6ee641e3920015f90.debug /usr/lib/debug/.build-id/29/7b84e734b909f1c60bc404301ec6c10927672e.debug /usr/lib/debug/.build-id/2a/915fae218dcc09b608182e6c3e2d8b21df3423.debug /usr/lib/debug/.build-id/2b/1bee171e4fe740b60e6690015312b9b6a71e04.debug /usr/lib/debug/.build-id/2d/b065f1f261f365994e1f05f0e1af6f7d38918a.debug /usr/lib/debug/.build-id/2e/a6e43926890f401caf469637f5488ae29611dd.debug /usr/lib/debug/.build-id/33/7dac361bc8a7a67c7652b6775db66a5804f612.debug /usr/lib/debug/.build-id/3a/e2f8cdb5f78e69e542c2e6e338ce4bfc522e9c.debug /usr/lib/debug/.build-id/3c/19c4d50a46c26867b58f3935d7274c70e5c291.debug /usr/lib/debug/.build-id/3c/7f6150205c8925d7073c96d5f203cdb3b641de.debug /usr/lib/debug/.build-id/3d/94efc5392e96c67f99ea0d88549792c1b3a0f9.debug /usr/lib/debug/.build-id/3d/a9988d3aed1fc941f39a086cc847f38a20b27d.debug /usr/lib/debug/.build-id/41/16dc638773707271593f58189e2b75f2dbe159.debug /usr/lib/debug/.build-id/42/7318892c94588c6d79bb4991486fa92ef3c960.debug /usr/lib/debug/.build-id/42/cb832a25c99cdca6aa24807f5a555280d915ce.debug /usr/lib/debug/.build-id/45/92bc1e8ba0fde2b715d9dedbe94e218eba09de.debug /usr/lib/debug/.build-id/50/149265f20c4debcc30f8248c4fa086f945a855.debug /usr/lib/debug/.build-id/55/df7a794c3bc8790539a7f7ef6c514a46df0a4b.debug /usr/lib/debug/.build-id/56/14138b804f0591977612e6a0b4981369c7e16f.debug /usr/lib/debug/.build-id/5a/24d8595665991cba7effd79a9674779a1107f3.debug /usr/lib/debug/.build-id/5e/7cdd28919af439afaeb54e6878f0d6b3175ea5.debug /usr/lib/debug/.build-id/72/1dc6fcf0fe50082620b51af31910d1e4881914.debug /usr/lib/debug/.build-id/76/4ac9270151511dbea4b78d571692dfd14f561f.debug /usr/lib/debug/.build-id/77/58d609403354cd76d903a5ee0d0f4f7322f71d.debug /usr/lib/debug/.build-id/7c/74c466cac7f7f981a3240e1ab0586a79f0d0f0.debug /usr/lib/debug/.build-id/81/5e2f7db79bc0d14240e6554a0a436e14a23046.debug /usr/lib/debug/.build-id/82/f1e1100594f40a704b922e062bbb75bc38279b.debug /usr/lib/debug/.build-id/86/388075303283a78ccf027e0e58b6939671ce3d.debug /usr/lib/debug/.build-id/87/87d1c798fc8bf00b0826340d3896f46482b745.debug /usr/lib/debug/.build-id/87/9ef92e271df8b76afa587f05f085d8b3b346ac.debug /usr/lib/debug/.build-id/89/d18c52c6779f4c64716bdd6c2e38560caaa82a.debug /usr/lib/debug/.build-id/8a/e7bb8df77cf7fa71cbcd68cf6abca1b1bd37d4.debug /usr/lib/debug/.build-id/8c/ea5a13fe87502d35bb07d244695e1458b757f0.debug /usr/lib/debug/.build-id/8f/e975f73569a1c4177c16c8400cfa10e1a042d9.debug /usr/lib/debug/.build-id/90/7663f8d4e6fc9bab5b4e063d39e02dd3cb9fba.debug /usr/lib/debug/.build-id/95/74eb17d99846ad456596412d9d4ce3f7b7bb12.debug /usr/li
Comment 2 Place Holder 2010-05-05 07:43:21 EDT
Hmmm.. yep, its more than likely something gone way wrong with yum/packagekit... but I STILL think that ABRT shouldn't just hang forever...

$ ps -ef | grep -i package
root       302     1  0 07:33 ?        00:00:00 /usr/sbin/packagekitd
root       348   302  0 07:36 ?        00:00:00 /usr/bin/python /usr/share/PackageKit/helpers/yum/yumBackend.py get-distro-upgrades
nick       353   306  0 07:39 pts/2    00:00:00 grep -i package

$ su -
Password: 

[root]# kill -HUP 2760
[root]# yum clean all
Loaded plugins: presto, refresh-packagekit
Existing lock /var/run/yum.pid: another copy is running as pid 348.
Another app is currently holding the yum lock; waiting for it to exit...
  The other application is: PackageKit
    Memory :  24 M RSS (319 MB VSZ)
    Started: Wed May  5 07:36:44 2010 - 03:11 ago
    State  : Uninterruptible, pid: 348
[...]
^C
Exiting on user cancel.

[root]# ps -ef | grep 348
root       348   302  1 07:36 ?        00:00:02 /usr/bin/python /usr/share/PackageKit/helpers/yum/yumBackend.py get-distro-upgrades
root       433   366  0 07:40 pts/2    00:00:00 grep 348
Comment 3 Place Holder 2010-05-06 10:32:11 EDT
The inability to actually install the debug-info's is most likely being caused by the issue reported in bug# 589603.
Comment 4 Denys Vlasenko 2010-05-06 14:45:38 EDT
Is there an option for yum to abort if yum lock is taken? That would allow to solve this problem.
Comment 5 Fedora Update System 2011-03-27 13:37:07 EDT
abrt-2.0.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-1.fc15
Comment 6 Fedora Update System 2011-03-29 16:02:36 EDT
abrt-2.0.0-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-2.fc15
Comment 7 Fedora Update System 2011-03-29 22:33:04 EDT
Package abrt-2.0.0-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.0-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.0-2.fc15
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2011-03-30 12:49:19 EDT
abrt-2.0.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-3.fc15
Comment 9 Fedora Update System 2011-04-04 10:09:08 EDT
abrt-2.0.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-4.fc15
Comment 10 Fedora Update System 2011-04-15 11:10:14 EDT
abrt-2.0.0-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.0-5.fc15
Comment 11 Fedora Update System 2011-04-20 09:30:54 EDT
abrt-2.0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.1-1.fc15
Comment 12 Fedora Update System 2011-04-21 12:45:25 EDT
abrt-2.0.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.1-2.fc15
Comment 13 Fedora Update System 2011-04-26 12:12:47 EDT
abrt-2.0.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.