Bug 58914 - gnome using incompatible libpng versions
gnome using incompatible libpng versions
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: libpng (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-27 15:08 EST by sean
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-27 15:08:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2002-01-27 15:08:48 EST
Description of Problem:
png icons don't appear on XFree

Version-Release number of selected component (if applicable):
libpng-1.2.1-2
libpng10-1.0.12-3

How Reproducible:


Steps to Reproduce:
1. startx
2. 
3. 

Actual Results:
output from startx:

(==) Log file: "/var/log/XFree86.0.log", Time: Sun Jan 27 14:18:39 2002
(==) Using config file: "/etc/X11/XF86Config-4"
XIM DEBUG: SESSION_MANAGER=local/localhost.localdomain:/tmp/.ICE-unix/12904
libpng warning: Application was compiled with png.h from libpng-1.2.1
libpng warning: Application  is running with png.c from libpng-1.0.12
libpng error: Incompatible libpng version in application and library


Now libpng-1.0.12 is not installed (  presumably when libpng10 was installed ).

From reading the newgroups, this appears to happen if  the older header is found
first on execution. I have two png.h's:

/usr/include/png-1.0/png.h
/usr/include/png.h    <------  this is from 1.2.1

libpng.so.2 and so.3  are in /usr/lib

FWIW, I've rebuilt gdk-pixbuf, gnome-core, gnome-libs and XFree86 , since iI
don't know what "application" is being referred to.



Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-01-28 08:26:58 EST
Don't rebuild them.

The gnome-* stuff is linked against the old libpng for binary compatibility
reasons, therefore gnome applications shouldn't link to the current libpng (they
should all use -lpng-1.0), the way they do in our packages.

The new libpng is used by everything that isn't gnome and by gnome 2.x stuff.
Comment 2 Jeffrey C. Ollie 2002-01-29 11:49:40 EST
I've seen this too, and not because I've recompiled anything - this happens 
straight from the binary Raw Hide RPMS.

Jeff

Note You need to log in before you can comment on or make changes to this bug.