Bug 58921 - /usr/lib/libaudiofile.la missing
/usr/lib/libaudiofile.la missing
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: audiofile (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-27 17:51 EST by Fabrice Bellet
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-28 04:59:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2002-01-27 17:51:33 EST
is it possible to add this file to the devel package, so
galeon can build properly.
Comment 1 Havoc Pennington 2002-01-27 18:45:15 EST
What's the error message? I don't see why Galeon would fail to build due to this.

The only reason it would is if some other .la file was compiled with
libaudiofile.la installed, and thus contains a hardcoded reference to 
libaudiofile.la.
Comment 2 Fabrice Bellet 2002-01-28 04:59:34 EST
Exact! This is my fault.
I previously installed ximian audiofile-devel containing libaudiofile.la,
then I manually built some other GNOME sources, and references to
/usr/lib/libaudiofile.la have been spread in other .la files. Coming
back to redhat audiofile-devel caused the problem to appear.
Comment 3 Havoc Pennington 2002-02-08 18:18:55 EST
Decided on a preliminary policy of "no .la files", so closing the bug.
Now we need bugs on all GNOME packages that _do_ have the files. ;-)
Comment 4 major 2002-08-24 09:44:19 EDT
The RedHat package "audiofile-0.2.3-3.src.rpm" has a small error in the spec
file that causes libaudiofile.la to not get included in the audiofile-devel
package even though the file is built. The "%files devel" section consists of
the following:

%files devel
%defattr(-, root, root)
%{_bindir}/audiofile-config
%{_libdir}/lib*.so
%{_libdir}/*.a
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*
%{_datadir}/aclocal/*

which does have a line for "%{_libdir}/libaudiofile.a" but not
"%{_libdir}/libaudiofile.la". I have seen this fixed in other spec files by
changing "*.a" to "*a", thus including any file that ends with "a".

I recommend changing "*.a" to "lib*.a", adding "lib*.la", and adding "lib*.so.*"
 so that the library prefix "lib" and suffixes "a", "la", and "so" are obvious
and any files with a version on "so" are included by default. The section would
look something like the following.

%files devel
%defattr(-, root, root)
%{_bindir}/audiofile-config
%{_libdir}/lib*.a
%{_libdir}/lib*.la
%{_libdir}/lib*.so
%{_libdir}/lib*.so.*
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*
%{_datadir}/aclocal/*

I have seen this oversight in the Ximian audiofile packages and analogous
oversights concerning "lib*.la" in other packages from RedHat, Ximian, and
others. Also, many libraries do not have the "lib" prefix on file names,
although it seems to be a useful convention, and would need to exclude it from
globs, using "*.a", "*.la", "*.so", and "*.so.*" instead.
Comment 5 Havoc Pennington 2002-08-24 11:08:31 EDT
major, the non-inclusion of .la files isn't an error, it's a deliberate policy.

Note You need to log in before you can comment on or make changes to this bug.