Bug 589229 - Errors from old libvirt daemon return ERR_RPC
Errors from old libvirt daemon return ERR_RPC
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: v2v-libvirt (Show other bugs)
5.6
All Linux
low Severity medium
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On: 589237
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 11:48 EDT by Matthew Booth
Modified: 2012-07-13 06:02 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.8.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 589237 (view as bug list)
Environment:
Last Closed: 2012-07-13 06:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2010-05-05 11:48:41 EDT
Description of problem:
virt-v2v connecting to a RHEL 5 libvirt daemon returns:

# virt-v2v -f virt-v2v.conf -op transfer -oc qemu:///system rhel39pae
libvirt error code: 39, message: unmarshalling remote_error

The relevant output of the daemon at the time running with LIBVIRT_DEBUG=1 is:

15:48:59.446: debug : virDomainLookupByName:1771 : conn=0x52f0310, name=rhel39pae
15:48:59.447: error : Domain not found: no domain with matching name 'rhel39pae'
libvir: QEMU error : Domain not found: no domain with matching name 'rhel39pae'

virt-v2v run with LIBVIRT_DEBUG=1 outputs:

16:07:08.957: debug : virDomainLookupByName:2127 : conn=0xdf3edd0, name=rhel39pae
16:07:08.957: debug : remoteIO:9650 : Do proc=23 serial=2 length=44 wait=(nil)
16:07:08.957: debug : remoteIO:9711 : We have the buck 23 0xdfde540 0xdfde540
16:07:08.957: debug : remoteIODecodeMessageLength:9095 : Got length, now need 204 total (200 more)
16:07:08.957: debug : remoteIOEventLoop:9597 : Giving up the buck due to I/O error 23 0xdfde540 (nil)

Dan Berrange has tracked the root cause to change 965466c1, which added a field to struct remote_error.

Version-Release number of selected component (if applicable):
v2v-libvirt-0.8.0-2.el5
libvirt-0.6.3-33.el5
Comment 1 Matthew Booth 2010-05-17 04:39:34 EDT
Fixed in 0.8.1-1

Note You need to log in before you can comment on or make changes to this bug.