Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 589275 - ec2 driver is not returning images correctly
ec2 driver is not returning images correctly
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Retired
Component: deltacloud-core (Show other bugs)
0.3.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Michal Fojtik
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-05 13:40 EDT by Sayli Karmarkar
Modified: 2015-03-22 21:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sayli Karmarkar 2010-05-05 13:40:21 EDT
Description of problem:
1. ec2 driver seems to be returning aki and ari along with ami. It should be returning only ami.
2. It is returning images only owned by amazon and not any other images like private images. It should be able to return all images that user has access to.  


Steps to Reproduce:
start deltacloud server with ec2 driver and go to http://serverurl:3001/api/images

  
Actual results:
List of ami, aki and ari with owner amazon.  

Expected results:
All ami that user has access to (no seperate aki and ari), possibly user can specify owner as a parameter.
Comment 1 wes hayutin 2011-01-26 12:27:12 EST
This looks fixed to me, the list only has ami's 

ami-20b05349 	ami-20b05349 	205605819716 	i386 	aws-console-quickstart-amis/perl/1.3/perlquickstart.manifest.xml
ami-22b0534b 	ami-22b0534b 	205605819716 	i386 	aws-console-quickstart-amis/ruby/1.2/rubyquickstart.manifest.xml
ami-27e7004e 	ami-27e7004e 	205605819716 	i386 	/aws-console-quickstart-amis/p
Comment 2 wes hayutin 2011-08-01 16:01:47 EDT
release pending...
Comment 3 wes hayutin 2011-08-01 16:02:11 EDT
release pending...
Comment 4 wes hayutin 2011-08-01 16:02:14 EDT
release pending 3
Comment 5 wes hayutin 2011-08-01 16:02:25 EDT
release pending.. 2
Comment 7 wes hayutin 2011-12-08 09:01:20 EST
perm close
Comment 8 wes hayutin 2011-12-08 09:04:16 EST
closing out old bugs

Note You need to log in before you can comment on or make changes to this bug.