Bug 58934 - Why do I need cups library for Qt !?
Why do I need cups library for Qt !?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: qt (Show other bugs)
1.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-28 04:39 EST by Mario Mikocevic
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-28 06:47:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Mikocevic 2002-01-28 04:39:15 EST
Description of Problem:
# rpm -Uvh --force qt-3.0.2-0.cvs20020118.2.i386.rpm
qt-devel-3.0.2-0.cvs20020118.2.i386.rpm 
error: failed dependencies:
        libcups.so.2   is needed by qt-3.0.2-0.cvs20020118.2
        libcups.so.2   is needed by qt-devel-3.0.2-0.cvs20020118.2

Option --force is because of a release quirk (-1.cvs vs -0.cvs) so please
this time ignore that.

Why do I need cups library for Qt !?
Is this requirement now permanent and mandatory !?

Version-Release number of selected component (if applicable):


How Reproducible:
Always

Steps to Reproduce:
1. rpm -Fvh qt*
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-01-28 06:47:34 EST
Qt's QPrinter class uses libcups to get a list of available printers if cups is
being used, so this is intentional.

However, since only one function (cupsGetDests()) is used and loading libcups
even for applications that don't print at all is a waste of space, I'll probably
replace this with a dlopen call in the next build.
Comment 2 Bernhard Rosenkraenzer 2002-04-05 05:00:18 EST
It uses dlopen now.

Note You need to log in before you can comment on or make changes to this bug.