Bug 589358 - SELinux is preventing /usr/bin/kdm "execute" access on /sbin/grub.
SELinux is preventing /usr/bin/kdm "execute" access on /sbin/grub.
Status: CLOSED DUPLICATE of bug 540213
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-05-05 18:56 EDT by Kayo
Modified: 2010-11-03 17:39 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-05-06 03:40:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kayo 2010-05-05 18:56:16 EDT

SELinux is preventing /usr/bin/kdm "execute" access on /sbin/grub.

Szczegółowy opis:

SELinux denied access requested by kdm. It is not expected that this access is
required by kdm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Zezwalanie na dostęp:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug

Dodatkowe informacje:

Kontekst źródłowy          system_u:system_r:xdm_t:s0-s0:c0.c1023
Kontekst docelowy             system_u:object_r:bootloader_exec_t:s0
Obiekty docelowe              /sbin/grub [ file ]
Źródło                     kdm
Ścieżka źródłowa         /usr/bin/kdm
Port                          <Nieznane>
Komputer                      (removed)
Źródłowe pakiety RPM       kdm-4.4.2-5.fc12
Docelowe pakiety RPM          grub-0.97-62.fc12
Pakiet RPM polityki           selinux-policy-3.6.32-113.fc12
SELinux jest włączony       True
Typ polityki                  targeted
Tryb wymuszania               Enforcing
Nazwa wtyczki                 catchall
Nazwa komputera               (removed)
Platforma                     Linux (removed) #1 SMP Mon
                              Apr 5 16:32:08 EDT 2010 i686 i686
Liczba alarmów               1
Po raz pierwszy               śro, 5 maj 2010, 23:53:33
Po raz ostatni                śro, 5 maj 2010, 23:53:33
Lokalny identyfikator         5b98bde3-0604-4c7d-8471-47563fd2a7bd
Liczba wierszy                

Surowe komunikaty audytu      

node=(removed) type=AVC msg=audit(1273096413.63:735): avc:  denied  { execute } for  pid=2359 comm="kdm" name="grub" dev=dm-3 ino=565279 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:bootloader_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1273096413.63:735): arch=40000003 syscall=33 success=no exit=-13 a0=bfccd711 a1=1 a2=bfccff8e a3=bfccff89 items=0 ppid=1 pid=2359 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash String generated from  catchall,kdm,xdm_t,bootloader_exec_t,file,execute
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t bootloader_exec_t:file execute;
Comment 1 Miroslav Grepl 2010-05-06 03:40:15 EDT

*** This bug has been marked as a duplicate of bug 540213 ***

Note You need to log in before you can comment on or make changes to this bug.