Bug 58937 - .spec file for licq does not have dependency from KDE libraries, although KDE is required to rebuild package from SRPMS
.spec file for licq does not have dependency from KDE libraries, although KDE...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: licq (Show other bugs)
1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-28 05:45 EST by Dennis Dementiev
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-28 05:45:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Dementiev 2002-01-28 05:45:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011222

Description of problem:
I do not use KDE, it is not installed in my system. However I do use QT and it
is installed. Due to some reasons I decided to rebuild licq with QT 3.0.0. The
problem is that licq-kde is always builded from SRPMS. However, KDE libraries
are not specified in BuildRequires tag of spec file. Therefore in my case build
started but creating package failed cause licq-kde plugin of course was not
compiled in my system due to absence of KDE libraties.

How reproducible:
Always

Steps to Reproduce:
1. Remove KDE libraries from your system and try to rebuild licq from SRPMS
Comment 1 Karsten Hopp 2002-07-24 06:20:29 EDT
You have to edit the spec file and disable licq-kde by  
setting the buildkde variable to 0. If this variable doesn't  
exist in your spec file, get the latest SRPM from Rawhide.

Note You need to log in before you can comment on or make changes to this bug.