Bug 58941 - Why does rpm think new libxml packages is older?
Summary: Why does rpm think new libxml packages is older?
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: libxml   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-28 13:17 UTC by Jonathan Kamens
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-14 22:35:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2002-01-28 13:17:19 UTC
jik:/usr/src/packages/new!351> rpm -U --test libxml-1.8.17-1.i386.rpm 
package libxml-1.8.16-3 (which is newer than libxml-1.8.17-1) is already
installed

Comment 1 Daniel Veillard 2002-01-28 13:39:40 UTC
Because I forgot to set the Epoch (this thing drives me nuts !).

Daniel

Comment 2 Rick Jenkins 2002-03-14 22:35:36 UTC
rpm isn't the only package to be fooled.

A number of gnome packages rely on gnome-config to report their version number.
For most packages, gnome-config in turn calls /usr/lib/<LIBRARY>Conf.sh to
obtain the information. These latter scripts typically return a literal string
into MODVERSION. 

In at least the  libxml-1.8.17-2.i386.rpm, libgnomeprint15-0.30-4.i386.rpm, and
libole2-0.2.4-2.i386.rpm packages from RedHat, and I suspect in others, the
<LIBRARY>Conf.sh has been omitted. After installing the package, gnome-config
continues to report the older version which has been upgraded.

I'm beginning to think that the version information resides in too many places.
Keeping them synchronised has become too difficult. We need exactly one 
standardised way to report version numbers, built right into the code so that it
can't be spoofed.



Comment 3 Daniel Veillard 2002-08-29 09:46:45 UTC
Gnome config is for compilation issues. The epoch and rpm versionning
are at the binary package level. They are different issues.
Anyway libxml is getting deprecated, libxml2 is the package to use.
I don't expect to make any new libxml (version 1) release at this
point so the problem should vanish by itself,

Daniel


Note You need to log in before you can comment on or make changes to this bug.