Bug 589420 - [Alviso] DRI on Intel 915GM/GMS/910GML doesn't work
[Alviso] DRI on Intel 915GM/GMS/910GML doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
i686 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 01:39 EDT by sd.domrep
Modified: 2018-04-11 05:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-07 15:25:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (23.24 KB, text/plain)
2011-03-25 12:37 EDT, sd.domrep
no flags Details
Dmesg (68.20 KB, text/plain)
2011-03-25 12:38 EDT, sd.domrep
no flags Details
Messages (44.81 KB, text/plain)
2011-03-25 12:41 EDT, sd.domrep
no flags Details

  None (edit)
Description sd.domrep 2010-05-06 01:39:23 EDT
Description of problem:
When I start glxgears or 3D OpenGL game (quake for example) it shows FPS = 20-25FPS.
But as long as it now synchronized with VRR it should be ~60FPS.
I can get 58FPS only if together with glxgears I start to play movie, or start to move mouse cursor quickly around the screen.
Otherwise I get only 20-25FPS.
Noticeably in compiz, everything not smooth, but not sure it is connected one to other.

Version-Release number of selected component (if applicable):
Fedora 13 with all latest updates. Kernel 33.3-79
Video chipset i915GM

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Can provide additional information by request, as long there is no any errors.
Comment 1 sd.domrep 2010-05-06 10:44:59 EDT
xorg-x11-drv-intel-2.11.0-4.fc13 the same result on i195GM
Comment 2 sd.domrep 2010-05-07 20:08:46 EDT
Dear All.
Just for the information:
kernel .33-85
xorg-x11-server 1.8.0-12.fc13
xorg-x11-drv-intel-2.11.0-4.fc13

Result the same.
98 frames in 5.1 seconds = 19.359 FPS
81 frames in 5.0 seconds = 16.171 FPS
94 frames in 5.0 seconds = 18.618 FPS

Quick mouse movement around the screen:
273 frames in 5.0 seconds = 54.570 FPS
301 frames in 5.0 seconds = 60.101 FPS
296 frames in 5.0 seconds = 59.103 FPS

Thanks.
Comment 3 Howard Ning 2010-05-08 21:18:22 EDT
The glxgear can not do benchmark. In real game, it performs very well.
The sentense "Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate." mean it should be at 50 fps. Please use openarena or nexuiz to do benchmark.
Comment 4 sd.domrep 2010-05-09 19:49:05 EDT
I do not understand how many times I have to tell you that I do not want to measure anything.
I use glxgears to see current FPS and they exactly the same that game shows me (Quake).
Please read my thread.
http://forums.fedoraforum.org/showthread.php?t=244492

I want to have always 60 FPS no matter what I do - move my mouse or play a movie.
Right now I have 12-20FPS if I do nothing and games and glxgears shows me the same. 
Quake FPS jumps from 20 to 60.
Comment 5 sd.domrep 2010-05-09 20:14:04 EDT
And more important that glxgears and quake on my i686 i915GM
IS NOT SYNCHRONIZED TO THE VERTICAL REFRESH

because I got ANY FPS except of 60, which is my VRR.
Comment 6 sd.domrep 2010-05-20 18:52:27 EDT
I am happy to say that I found source of my problems.
DRI2 module.

As long as I start Xorg with "Disable DRI2" in module section I have normal picture and I have normal smooth rotatin of the gears in "glxgears" test.
Output of the "glxgears" without dri2 module:
565 frames in 5.0 seconds = 112.932 FPS
559 frames in 5.0 seconds = 111.726 FPS
558 frames in 5.0 seconds = 111.590 FPS
554 frames in 5.0 seconds = 110.797 FPS
569 frames in 5.0 seconds = 113.742 FPS
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
      after 6301 requests (36 known processed) with 0 events remaining.

Output of TOP:
1676 vas       20   0 15784 4868 1760 R 52.6  0.3   0:03.75 glxgears
1032 root      20   0 53664  12m 7124 S 39.9  0.8   0:50.63 X

Of course there is no H/W acceleration.
Comment 7 sd.domrep 2010-05-20 23:18:17 EDT
Glxgears output WITH DRI2 module loaded:
98 frames in 5.1 seconds = 19.359 FPS
81 frames in 5.0 seconds = 16.171 FPS
94 frames in 5.0 seconds = 18.618 FPS

Look like hardware acceleration "REALLY" helps

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
Comment 8 sd.domrep 2010-05-21 19:08:11 EDT
Hello.

I would like to remind you, that H/W OpenGl acceleration on my card doesn't really work.
And it has not worked since Fedora 12. DRI2 module makes screen picture unusable.
Can some one please pay attention to this problem.

Or if
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML
Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express
Graphics Controller (rev 04) 
is not supported anymore, I would like to see official announcement.

Thank you.
Comment 9 sd.domrep 2011-03-13 04:12:37 EDT
Dear All.

It looks like no one care about this problem, but it does still exist and exist it Fedora 15/16 with server-1.10.0-3 + drv-intel-2.14.0-3+kernel-2.6.35.11-83.fc14.
(I installed new xserver on fedora 14)

I still have 00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller, and glxgears said that FPS should be the same as VSYNC.

It is not - it is 17~15 fps.
It can be ~60 only when I am moving mouse around.

And actually screen picture is awful, it become better only when DRI -in "no" in xorg.conf
So I start to think that may be DRI is not synchronized with vsync at all?

Thanks for reading.
Comment 10 Matěj Cepl 2011-03-25 09:04:24 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 11 sd.domrep 2011-03-25 12:37:23 EDT
Created attachment 487595 [details]
Xorg log file
Comment 12 sd.domrep 2011-03-25 12:38:49 EDT
Created attachment 487599 [details]
Dmesg
Comment 13 sd.domrep 2011-03-25 12:41:19 EDT
Created attachment 487600 [details]
Messages
Comment 14 sd.domrep 2011-03-25 13:07:09 EDT
To tell the truth, in order to use fedora 15 picture output on my laptop LSD (LVDS-1) for more then 30 min. I have to change a lot:
in grub:
lpj=2000000
i915.powersave=0
in xorg.conf:
Option "DRI" "no"
Option "SwapbuffersWait" "no"
Modeline "1024x768_60.00"  64.11  1024 1080 1184 1344  768 769 772 795  -HSync +Vsync (made bu gtf)

I do not know what of those help, but it makes LCD screen picture very similar to the 4 years old opensuse 11.1, but unfortunately not exactly.

Thank you.
Comment 15 sd.domrep 2011-03-25 16:19:07 EDT
Sorry, I have not been clear enough about screen picture on my LCD. Without any adjustments picture looks like LCD uses 50 Hz or less vrr. You can imagine what I see, and it starts since X11R7.5. I check as much as I can on this laptop: freebsd, debian, last opensuse - always the same results - unusable screen picture and this bug with glxgears.
Video chipset:
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)

X server 1.5.2 (opensuse 11.1) works absolutely perfect and glxgears gives me:
3300 frames in 5.0 seconds = 659.962 FPS
3331 frames in 5.0 seconds = 666.099 FPS
with XAA acceleration.
Comment 16 Fedora End Of Life 2012-08-07 15:25:06 EDT
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.