Bug 58945 - qmkbootdisk
Summary: qmkbootdisk
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdeadmin (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-28 14:22 UTC by Giuseppe Raimondi
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 19:29:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Giuseppe Raimondi 2002-01-28 14:22:00 UTC
Description of Problem:
if you start qmkbootdisk as normal user you may think it actually created a bootdisk

Version-Release number of selected component (if applicable):
kdeadmin-2.2.2-2

How Reproducible:
always

Steps to Reproduce:
1. launch qmkbootdisk as user
2. select device and kernel
3. click ok

Actual Results:
you don't get any boot disk and no error messages or warnings at all

Expected Results:
either a request for root password (like many other tools) or a message saying
the bootdisk couldn't be created

Additional Information:
if you start qmkbootdisk in a shell you actually get a "Cannot find root
partition in /etc/fstab" message. What if you start it from Gnome/KDE panel?
there's no warning there... just an 100% ok which makes you think the floppy is
created

Comment 1 Gerald Teschl 2002-03-06 16:38:52 UTC
I guess this is due to the use of labels rather than devices in fstab.
Probably it should be linked against console-helper.

Comment 2 Giuseppe Raimondi 2002-03-07 09:26:00 UTC
I'm not sure about it, since if you run it in a root shell it does exactly what
you expect.

Comment 3 Ngo Than 2002-10-06 12:17:50 UTC
it needs console-helper.It's fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.