Bug 589451 - parted should recognize msdos partition id 27h as a diagnostics partition
parted should recognize msdos partition id 27h as a diagnostics partition
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-05-06 04:06 EDT by Hans de Goede
Modified: 2010-05-07 01:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: parted-2.1-8.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 589473 (view as bug list)
Environment:
Last Closed: 2010-05-07 01:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2010-05-06 04:06:39 EDT
Microsoft recommends using id 27 for recovery partitions:
http://technet.microsoft.com/en-us/library/dd744364%28WS.10%29.aspx

And anaconda depends on parted to identify these partitions as such, so as to keep them out of grub.conf (see bug 534066).

However parted currently does not recognize an id of 27 as a diagnostics partition, that needs to be fixed.
Comment 1 Hans de Goede 2010-05-06 04:51:51 EDT
Note for the F13Blocker review, fixing this bug is needed to truly fix bug 534066, which was approved as an F13Blocker.
Comment 2 Fedora Update System 2010-05-06 05:19:52 EDT
parted-2.1-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/parted-2.1-8.fc13
Comment 3 Adam Williamson 2010-05-06 07:16:27 EDT
hence should be modified...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Kamil Páral 2010-05-06 07:38:34 EDT
So, how can I test it?
Comment 5 Hans de Goede 2010-05-06 07:45:25 EDT
(In reply to comment #4)
> So, how can I test it?    

What arch are you using, x86_64 or i686 ? (Then I can do an updates.img for you)
Also what version of F-13 are you using as a base for your tests ?
Comment 6 Kamil Páral 2010-05-06 08:20:53 EDT
(In reply to comment #5)
> What arch are you using, x86_64 or i686 ? (Then I can do an updates.img for
> you)
> Also what version of F-13 are you using as a base for your tests ?    

x86_64, F13 Final TC1

I think it's not needed to test this in installer, installing parted and trying out should be enough, shouldn't it? But I need to know how to test it, because I don't know. I can create partition with id 27, but just tell me how to distinguish if parted sees it as diagnostics partitions or not.
Comment 7 Adam Williamson 2010-05-06 09:26:24 EDT
kamil: we should really re-test the installer with the new parted, to confirm the fix and test for regressions.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Hans de Goede 2010-05-06 14:26:44 EDT
Ok, here is an updates.img for testing installs with the fix:
http://people.fedoraproject.org/~jwrdegoede/updates-589451-x86_64.img

As the name suggests this one is arch specific.
Comment 9 Fedora Update System 2010-05-06 23:56:12 EDT
parted-2.1-8.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update parted'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/parted-2.1-8.fc13
Comment 10 Paul W. Frields 2010-05-07 00:32:54 EDT
Jesse Keating built an image containing this morning's branched content, plus the new parted.  I tested it on a VM containing:

sda1 -- NTFS-formatted, bootable WinXP system
sda2 -- vfat-formatted, 0x27 type partition
sda3 -- leftover LVM PV

I chose custom layout, deleted the VG and PV, made a new sda3 /boot ext4, and a sda5 LVM PV, standard-ish content.  At boot loader screen, only sda1 and the new Fedora /boot were listed in the choices, as expected.
Comment 11 Fedora Update System 2010-05-07 01:48:34 EDT
parted-2.1-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.