Bug 58948 - Why was NDBM_File removed?
Summary: Why was NDBM_File removed?
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: perl (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-28 14:36 UTC by Jonathan Kamens
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 14:44:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2002-01-28 14:36:59 UTC
Why was NDBM_File removed from Perl?  Removing it breaks compatibility with
scripts that run just fine on other platforms.

Comment 1 Jonathan Kamens 2002-01-29 14:44:40 UTC
Also, if you insist on leaving it removed, then you need to obsolete the
perl-NDBM_File package in the new perl RPM, because the old package is
binary-incompatible with the newly compiled perl.


Comment 2 Chip Turner 2002-01-31 20:44:39 UTC
on linux, NDBM is just an alias for gdbm.  you can use AnyDBM_File for better
compatibility, or GDBM, which should also work.  I've added it as an obsoletes
in -24.


Note You need to log in before you can comment on or make changes to this bug.