Bug 589488 - Update conflicts initscripts.i686 0:9.12-1.fc13
Summary: Update conflicts initscripts.i686 0:9.12-1.fc13
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 589588 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 10:15 UTC by Joachim Backes
Modified: 2014-03-17 03:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-06 15:50:48 UTC
Type: ---


Attachments (Terms of Use)

Description Joachim Backes 2010-05-06 10:15:40 UTC
Description of problem:
Updating initscripts to  initscripts.i686 0:9.12-1.fc13 fails because of dependency problems:

sudo yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package initscripts.i686 0:9.12-1.fc13 set to be updated
--> Processing Conflict: initscripts-9.12-1.fc13.i686 conflicts NetworkManager < 1:0.8.0-12.git20100504
--> Finished Dependency Resolution
Error: initscripts conflicts with NetworkManager


Version-Release number of selected component (if applicable):
initscripts.i686 0:9.12-1.fc13                                                                                      


How reproducible:
Always

Steps to Reproduce:
1.yum update initscripts
2.
3.
  
Actual results:
See Description

Expected results:
update is done

Additional info:

Comment 1 iarly selbir 2010-05-06 12:40:44 UTC
same problem here.

Bill, we are needing something from NetworkManager maintainer?


Thanks for your report.


--
Fedora Bugzappers Team Member

Comment 2 Jonathan Billings 2010-05-06 13:46:00 UTC
Looks like there's a Conflicts in the initscripts that is causing this problem.
I did a yum update on my system without NetworkManager installed, which upgraded initscripts to initscripts-9.12-1.fc13, I downloaded the available NetworkManager package with 'yumdownloader', and ran:

# rpm -ivv --test NetworkManager-0.8.0-11.git20100503.fc13.x86_64.rpm

and saw this:

D: package initscripts-9.12-1.fc13.x86_64 has unsatisfied Conflicts: NetworkManager < 1:0.8.0-12.git20100504

This leads me to think that there's a NetworkManager 0.8.0-12* that hasn't hit the yum repos yet, and is causing this problem.

Comment 3 iarly selbir 2010-05-06 14:05:08 UTC
*** Bug 589588 has been marked as a duplicate of this bug. ***

Comment 4 Bill Nottingham 2010-05-06 15:50:48 UTC
That version of NetworkManager should be available in the latest branched F-13 tree.


Note You need to log in before you can comment on or make changes to this bug.