Bug 589506 - copying from http to local file ends with Generic error
copying from http to local file ends with Generic error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 06:37 EDT by Tomas Pelka
Modified: 2015-03-03 17:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-24 06:29:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Pelka 2010-05-06 06:37:08 EDT
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
gnome-vfs2-2.24.2-5.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. open terminal
2. run gnomevfs-copy http://www.google.com file:///home/tpelka/google.html
3.
  
Actual results:
Failed copy http://www.google.com to fileL///home/tpelka/google.html
Reason: Generic error

Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-05-06 08:23:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Tomáš Bžatek 2010-05-26 10:54:43 EDT
FYI this works properly with http://www.root.cz, started to think it's not our fault.
Comment 4 Tomas Pelka 2010-05-26 11:00:35 EDT
Confirmed, seems that only google is gvfs-unfriendly.  We can close this issue as NOTABUG probably.
Comment 5 Tomáš Bžatek 2010-05-26 11:06:54 EDT
(In reply to comment #4)
> Confirmed, seems that only google is gvfs-unfriendly.  We can close this issue
> as NOTABUG probably.    
This is gnome-vfs2, if it was gvfs, we get different error message but consistent erratic behaviour:

$ gvfs-copy http://www.google.com file:///tmp/google2.html
Error copying file http://www.google.com: Message Corrupt

Looking at this more to exclude the possibility of our fault.
Comment 6 RHEL Product and Program Management 2010-07-15 10:19:56 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 7 Tomáš Bžatek 2011-01-21 09:12:52 EST
(In reply to comment #5)
> $ gvfs-copy http://www.google.com file:///tmp/google2.html
> Error copying file http://www.google.com: Message Corrupt

This works for me now, looks like it was a temporary server fault on Google side.
Can you please retest and close if not valid?
Comment 8 Tomas Pelka 2011-01-24 06:29:16 EST
Works for me too.

Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.