Bug 589511 - error reporting to bugzilla - XML-RPC Fault(-504): HTTP response code is 502, not 200
error reporting to bugzilla - XML-RPC Fault(-504): HTTP response code is 502,...
Status: CLOSED DUPLICATE of bug 592929
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 06:51 EDT by Mads Kiilerich
Modified: 2014-02-02 17:14 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-13 06:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the error messages (87.07 KB, image/png)
2010-05-06 06:51 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2010-05-06 06:51:09 EDT
Created attachment 411924 [details]
the error messages

Description of problem:

abrt hangs when trying to file bugzilla reports (as root). The report is created, but abrt never finds out. After some (too long) time that causes a dbus message to be shown. Screenshot attached.

After closing the error message it says:
Reporting via 'Bugzilla' was not successful: XML-RPC Fault(-504): HTTP response code is 502, not 200


Version-Release number of selected component (if applicable):

abrt-1.1.0-1.fc13.i686
abrt-addon-ccpp-1.1.0-1.fc13.i686
abrt-addon-kerneloops-1.1.0-1.fc13.i686
abrt-addon-python-1.1.0-1.fc13.i686
abrt-cli-1.1.0-1.fc13.i686
abrt-desktop-1.1.0-1.fc13.i686
abrt-devel-1.1.0-1.fc13.i686
abrt-gui-1.1.0-1.fc13.i686
abrt-libs-1.1.0-1.fc13.i686
abrt-plugin-bugzilla-1.1.0-1.fc13.i686
abrt-plugin-catcut-1.1.0-1.fc13.i686
abrt-plugin-filetransfer-1.1.0-1.fc13.i686
abrt-plugin-logger-1.1.0-1.fc13.i686
abrt-plugin-mailx-1.1.0-1.fc13.i686
abrt-plugin-runapp-1.1.0-1.fc13.i686
abrt-plugin-sosreport-1.1.0-1.fc13.i686
abrt-plugin-ticketuploader-1.1.0-1.fc13.i686
Comment 1 Nikola Pajkovsky 2010-05-06 07:33:26 EDT
Thank you for report

run as root

service abrtd stop
abrtd -dvvv

try to reproduce bug and after it failed again attach log from abrtd -dvvv and
/var/log/messages
Comment 2 Mads Kiilerich 2010-05-06 08:00:35 EDT
FWIW I just got a 502 proxy error when trying to file a bug manually, so it seems like it was caused by some internal redhat network problems. In that case it also created the bug but never told me.

That explains what happened. I think abrt could handle such situations nicer than it did.

I have tried 100 times the last hour to post this message - let's see if it succeeds this time.
Comment 3 Mads Kiilerich 2010-05-06 08:12:24 EDT
Now it works and I can't reproduce the problem.
Comment 4 Nikola Pajkovsky 2010-05-06 08:14:39 EDT
But what I see wrong is the error table. This should not show up. Looks like
daemon dies.
Comment 5 Nikola Pajkovsky 2010-05-13 06:29:54 EDT
I will close it. If the problem shows up again run daemon as I mentioned in Comment 2 and reopen bug.
Comment 6 Denys Vlasenko 2010-05-20 14:03:05 EDT
This problem appeared again, as bug 592929. Reclassifying it as duplicate.

*** This bug has been marked as a duplicate of bug 592929 ***

Note You need to log in before you can comment on or make changes to this bug.