Bug 58952 - Still problems with 3ware 6800
Still problems with 3ware 6800
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-28 09:55 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 20:50:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-28 09:55:30 EST
Description of Problem:
On a machine with escalade boards: still sda device not seen by RH 7.2 
installer (using new fd images).

Version-Release number of selected component (if applicable):
?

How Reproducible:
?

Steps to Reproduce:
1. Install RH 7.2 from network 
2. Install option: server
3. Disk Partitioning Setup: Manually partition (Disk Druid or fdisk)


Actual Results:
 sda partition not seen.

Expected Results:
 

Additional Information:
 The used images: new bootnet.img and update-disk-20020117.img.
 Thied also: old bootnet.img and update-disk-20011009.img, same result.
             old bootnet.img alone, no partition seen.
 The hardware: Motherboard STL2 with 2x PIII @866, 512 MB RAM, gigabit ethernet
adapter, 3x 3W6800 boards, 2x 20 GB Quantum disks (for system) 20x 80 GB WDig 
disks (for data). The 3ware boards bios version is 1.02.03.053. The system
works fine with RedHat 6.2. All Hardware is verified to be OK.
Comment 1 Jeremy Katz 2002-01-28 12:28:14 EST
If you go over to tty2 and run lsmod, is the 3ware driver loaded?  If so, are
the devices listed in /proc/scsi/scsi?
Comment 2 Need Real Name 2002-01-29 03:47:19 EST
Hi,
 - 3ware driver is loaded and devices are listed in /proc/scsi/scsi
 - More infos:
   . All disks are configured RAID1
   . 1st board has 2x20GB disks for system (sda) and 4x80GB disks for data (sdb, sdc). The other two boards have 8x80GB disks each ( sdd->sdg, sdh->sdk).
     Devices sdb to sdk are seen. Device sda is seen but quoted as badly partitioned. If I acknowledge the request for formatting, it fails.
   . All boards came with last firmware installed. It's not clear to me if that requires the last 3ware driver (1.02.00.006, What's  the one included in RH 7.2 ?)...
     In any case everithing works fine with RH 6.2 and an even older 3ware driver.
   . Yesterday, just for test, I tried RH6.2 re-installation and it worked.
   . The machine is runnning under RH6.2 since half an year, no hardware failures happened, and no warnings came from 3ware disk management software  
   . Here are last lines I got when trying to install RH 7.2:
      ...
     <6> Journalled Block Device driver loaded
    <4>3w-xxxx: tw_interrupt(): Bad response, status = 0xC1, flag = 0x11, unit = 0x0.
    <4>3w-xxxx: tw_scsi_eh_reset(): Reset succeeded for card 2.
    <4>3w-xxxx: tw_interrupt():  Bad response, status = 0xC1, flag = 0x11, unit = 0x0.
    <6> scsi: device set offline - not ready or command retry failed after host reset: host 2 channel 0 id 0 lun 0
    <4> SCSI disk error : host 2 channel 0 id 0 lun 0 return code = 80000
    <4> I/O error. dev 08:00, sector 40130454
Comment 3 Need Real Name 2002-02-04 08:18:35 EST
Hi,
  I tried the same on a similar machine (that also works fine with RH 6.2). 
It just has different motherboard (Intel L440GX+, with 2x PIII @ 700 MHz) and 
disks (75 GB IBM disks). The problem is even bigger: no device is seen during
installation, whether I specify or not "update" option. I used last install
fd images. Regards, Benigno
Comment 4 Jeremy Katz 2002-02-11 00:52:22 EST
For the latter case, does it work if you also boot with 'linux updates noprobe'
and manually select the 3wsare driver?
Comment 5 Need Real Name 2002-02-14 05:45:51 EST
Sorry for the dealy: machines were in production.
With "linux updates noprobe" I got exactly the same result:
no /dev/sda device visible in 1st machine; no devices in 2nd.
Comment 6 Matt N 2002-02-19 04:56:35 EST
I've also got a problem with RH 7.2 + an escalade 6410.  I've got four ( WDC
WD300AB-00CDB) - western digital 30 GB drives attached to the escalade.  It
works just fine under 6.2 ( am using it now ).  The mother board is a dual
processor L440BX intel server board.  Whenever you try to install RH 7.2 ( and
this is either with the stock driver from Redhat, the updates disk, the 6.7
driver release from 3ware or any combination up to 6.9 from 3ware ) you start
getting the following in the kernel messages window ( this was with the 6.9
driver.. it's different depending on the driver release ):

SCSI Command Timed Out: (0xcf95a800)
( the board resets and does the same thing over again, but with 0xcf95ac00 as
the scsi command ).

After three times it stops scrolling the error message.  /proc/scsi/scsi shows
no attached drives and the /proc/scsi/3ware/2 lists 3 aborts.

I've even tried changing the version of firmware on the 3ware card around with
no luck.  I thought maybe you can't boot off of the 3ware card, so I installed
winnt4.0 to double check.  It booted, and then I immediately got rid of it.

Any suggestions are appreciated.  Sorry if it takes a while to answer.  I'm at
the South Pole right now and we don't have 24 hour internet access. 

Thanks,

Matt Newcomb
Amundsen Scott South Pole Station
Antarctica
Comment 7 Jeremy Katz 2002-02-22 18:47:33 EST
Arjan, I keep seeing reports of this even with the update disk, but we're doing
things "properly" now.  One reporter has said that an updated 3ware driver fixes
it.  Any ideas?
Comment 8 Need Real Name 2002-02-25 10:34:59 EST
I also tried 3ware 6.9 release. Results are the same.
Comment 9 Arjan van de Ven 2002-02-28 05:33:51 EST
Intel 440GX motherboards are technically unsupported by linux (thanks Intel!).
It MIGHT help if you type "apic" as option on the syslinux prompt.
Comment 10 Need Real Name 2002-03-11 05:50:28 EST
What about STL2 boards?
Comment 11 Arjan van de Ven 2002-03-11 06:01:36 EST
did apic help? if so it has the bios bug
Comment 12 Need Real Name 2002-03-11 07:36:21 EST
No, with apic the result is the same: 1st device (sda) missing
Comment 13 Need Real Name 2002-04-30 04:40:16 EDT
Done, at the end. As I got few e-mail from people with similar problems, it 
could be useful to tell what I did. Note that 3ware cards were all upgraded
to 6.9 software relase. I also upgraded motherborads BIOS but probably this was 
not necessary...

1) L440GX+ mboard
  It works with the apic option set (without it, no partition is visible):
  linux apic updates 

2) STL2 mboard
  I had to load the 3ware driver from release 6.9 (1.02.00.016) as with the
  driver loaded directly by the install disk stuff the sda partition was not
  visible):
  linux apic expert updates
  (insert 3ware driver fd when request)

                                         Thanks, benigno

Note You need to log in before you can comment on or make changes to this bug.