Bug 589522 - KickstartValueError: The following problem occurred on line 22 of the kickstart file: Specified nonexistent disk sda in partition command
Summary: KickstartValueError: The following problem occurred on line 22 of the kicksta...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Keywords:
: 589525 (view as bug list)
Depends On:
Blocks: 582286
TreeView+ depends on / blocked
 
Reported: 2010-05-06 11:18 UTC by Pavel Holica
Modified: 2010-05-10 15:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 14:20:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage.log (10.30 KB, text/plain)
2010-05-10 13:52 UTC, Pavel Holica
no flags Details
syslog (27.12 KB, text/plain)
2010-05-10 13:52 UTC, Pavel Holica
no flags Details

Description Pavel Holica 2010-05-06 11:18:40 UTC
The following was filed automatically by anaconda:
anaconda 13.21.32 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/kickstart.py", line 729, in execute
    raise KickstartValueError, formatErrorMsg(self.lineno, msg="Specified nonexistent disk %s in partition command" % n)
  File "/usr/lib/anaconda/kickstart.py", line 1132, in execute
    obj.execute(self.anaconda)
  File "/usr/bin/anaconda", line 1058, in <module>
    ksdata.execute()
KickstartValueError: The following problem occurred on line 22 of the kickstart file:

Specified nonexistent disk sda in partition command

Comment 1 Pavel Holica 2010-05-06 11:24:45 UTC
*** Bug 589525 has been marked as a duplicate of this bug. ***

Comment 3 Chris Lumens 2010-05-06 12:44:08 UTC
Does sda exist?  Please attach /tmp/syslog and /tmp/storage.log.

Comment 4 RHEL Product and Program Management 2010-05-06 13:35:02 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Pavel Holica 2010-05-10 13:52:12 UTC
Created attachment 412841 [details]
storage.log

No, sda doesn't exist.

Comment 6 Pavel Holica 2010-05-10 13:52:31 UTC
Created attachment 412842 [details]
syslog

Comment 7 Chris Lumens 2010-05-10 14:20:47 UTC
Then this is functioning as designed - kickstart is more strict now in what it will accept, and referring to a disk that does not exist is no longer accepted.

Comment 8 Pavel Holica 2010-05-10 15:32:42 UTC
I understand thad installation shouldn't continue.
But problem is, that this is traceback and user shouldn't see any traceback.
Please correct me if I'm wrong.

Comment 9 Chris Lumens 2010-05-10 15:36:31 UTC
It doesn't really matter here whether it's a traceback or not.  You still see the real error message, and the installation was going to halt right then anyway.  Functionally, there's no real difference between what you got and what you wanted to have.  I don't think there's really a need to work on handling that and redisplaying it in a slightly different format.


Note You need to log in before you can comment on or make changes to this bug.