Bug 589529 - cgred to support automated cgroup creation following a template
Summary: cgred to support automated cgroup creation following a template
Status: CLOSED DUPLICATE of bug 589535
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup   
(Show other bugs)
Version: 6.1
Hardware: All Linux
low
low
Target Milestone: rc
: ---
Assignee: Ivana Varekova
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-06 11:33 UTC by Ondrej Valousek
Modified: 2010-05-06 12:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 12:58:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ondrej Valousek 2010-05-06 11:33:20 UTC
Description of problem:
Situation: I have a Linux terminal server where multiple users log-in remotely. I need to limit every user to certain cpu/memory resources so he/she can not hog the machine.
Now the cgred daemon can do this task for me, but I would have to create a dedicated control group for every user manually for this to work.

Idea: Can be cgred daemon configured the way that for every user in some unix group that logs in, a new control group is created automatically (following a template) and every process the user launches is started in that group?

Does it make a sense?
Thanks.

Comment 2 Jan Safranek 2010-05-06 12:58:53 UTC

*** This bug has been marked as a duplicate of bug 589535 ***


Note You need to log in before you can comment on or make changes to this bug.