Bug 58955 - vsftpd-1.0.1-1 warnings ...
Summary: vsftpd-1.0.1-1 warnings ...
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vsftpd   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-28 15:28 UTC by R P Herrold
Modified: 2014-03-17 02:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-04 20:48:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R P Herrold 2002-01-28 15:28:03 UTC
Rebuilding the latest ,vsftpd-1.0.1-1,  I note it tosses off a couple of cast warnings:


gcc -c sysdeputil.c -O2 -march=i386 -mcpu=i686 -Wall -W -Wshadow  -idirafter dummyinc
sysdeputil.c: In function `vsf_sysdep_check_auth':
sysdeputil.c:203: warning: implicit declaration of function `crypt'
sysdeputil.c:203: warning: assignment makes pointer from integer without a cast
sysdeputil.c:211: warning: assignment makes pointer from integer without a cast
gcc -o vsftpd main.o utility.o prelogin.o ftpcmdio.o postlogin.o privsock.o tunables

Given the notorious scrutiny which FTP Daemons recieve for people looking for escalated priv's, it might make sence to add the prototype and 
explicit cast.

Comment 1 Bill Nottingham 2002-04-11 02:43:30 UTC
I can't reproduce this here... in all tests I run, it finds the prototype for
crypt just fine. (That's where the other two warnings come from as well,
assigning the results of crypt())


Note You need to log in before you can comment on or make changes to this bug.