Bug 589575 - FTBFS on Fedora
FTBFS on Fedora
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: inconsolata-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-06 09:14 EDT by Matěj Cepl
Modified: 2018-04-11 04:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 18:04:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new spec file (1.41 KB, text/plain)
2010-05-06 09:14 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2010-05-06 09:14:21 EDT
Created attachment 412014 [details]
new spec file

Description of problem:
When building the package on RHEL-6 (essentially F-12 with fontforge-20090622-2.1.el6.x86_64) I got this:

+ umask 022
+ cd /home/matej/build/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ exit 0
Provádění(%build): /bin/sh -e /var/tmp/rpm-tmp.kPypyn
+ umask 022
+ cd /home/matej/build/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ fontforge -script - /home/matej/build/SOURCES/Inconsolata.sfd
Copyright (c) 2000-2009 by George Williams.
 Executable based on sources from 22:35 GMT 22-Jun-2009.
 Library based on sources from 22:35 GMT 22-Jun-2009.
  File "<stdin>", line 2
    Open ($1)
          ^
SyntaxError: invalid syntax

I have changed spec as attached and now it works.

Version-Release number of selected component (if applicable):
inconsolata-fonts-1.009-2.el6.src.rpm

How reproducible:
100%

Steps to Reproduce:
1.rpmbuild --rebuild inconsolata-fonts-1.009-2.el6.src.rpm
2.
3.
  
Actual results:
crash

Expected results:
built package

Additional info:
Comment 1 Kevin Fenzi 2010-05-06 16:26:34 EDT
Where did you get this old package? I suggest you file this bug with whoever that is... RHEL6? 

The problem is that newer fontforge versions don't assume this is a fontforge script to build, so you need to add '-lang=ff' to the fontforge line. 

See any of the levien-inconsolata-fonts packages in Fedora, which all build fine. 

I don't know that there is anything for me to do here... you want to reassign this? Or should I just close it?
Comment 2 Matěj Cepl 2010-05-06 16:44:15 EDT
Well, I've got it in the last successful build at http://koji.fedoraproject.org/koji/packageinfo?packageID=5755. Is there anything more recent anywhere?
Comment 3 Kevin Fenzi 2010-05-06 16:51:37 EDT
The package was renamed... it's: 

levien-inconsolata-fonts

now. Per the new font guidelines. 

http://koji.fedoraproject.org/koji/packageinfo?packageID=7829
Comment 4 Matěj Cepl 2010-05-06 18:04:20 EDT
Yes, of course, I am silly ... the name may be unfortunately complicated, but levien-inconsolata-fonts rebuilds just fine.

Closing as PEBKAC aka NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.